summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-05-02 17:56:13 -0700
committerPatrick McLean <chutzpah@gentoo.org>2019-05-02 17:58:04 -0700
commit595f2ed23557752144263ebee8d1f05ce0c72dea (patch)
tree466aa07c89413174ae19bae3d20811e7e1e76cee /app-vim/vim-jsonnet/vim-jsonnet-0_pre20190502.ebuild
parentnet-irc/quassel: use HTTPS (diff)
downloadgentoo-595f2ed23557752144263ebee8d1f05ce0c72dea.tar.gz
gentoo-595f2ed23557752144263ebee8d1f05ce0c72dea.tar.bz2
gentoo-595f2ed23557752144263ebee8d1f05ce0c72dea.zip
app-vim/vim-jsonnet: New package
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'app-vim/vim-jsonnet/vim-jsonnet-0_pre20190502.ebuild')
-rw-r--r--app-vim/vim-jsonnet/vim-jsonnet-0_pre20190502.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-vim/vim-jsonnet/vim-jsonnet-0_pre20190502.ebuild b/app-vim/vim-jsonnet/vim-jsonnet-0_pre20190502.ebuild
new file mode 100644
index 000000000000..df90ee8b9a49
--- /dev/null
+++ b/app-vim/vim-jsonnet/vim-jsonnet-0_pre20190502.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vim-plugin
+
+COMMIT_HASH="824dcfe76568dba38135332fc4729e2b2c4d9b3a"
+
+DESCRIPTION="vim plugin: Filetype plugin for dev-lang/jsonnet"
+HOMEPAGE="https://github.com/google/vim-jsonnet"
+SRC_URI="https://github.com/google/vim-jsonnet/archive/${COMMIT_HASH}.tar.gz -> ${P}.tar.gz"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-lang/jsonnet"
+
+S="${WORKDIR}/${PN}-${COMMIT_HASH}"
+
+src_prepare() {
+ default
+
+ rm -f LICENSE .gitignore || die
+}