summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-08-17 17:07:01 -0400
committerTim Harder <radhermit@gentoo.org>2017-08-17 17:09:24 -0400
commit805d270a2d2ef1096d73ddc94a4d81dbf9005293 (patch)
tree26f8334516accd765c03783af9aed7464a139f52 /app-vim/vimagit/vimagit-1.7.2.ebuild
parentapp-vim/gitv: version bump to 1.3.1 (diff)
downloadgentoo-805d270a2d2ef1096d73ddc94a4d81dbf9005293.tar.gz
gentoo-805d270a2d2ef1096d73ddc94a4d81dbf9005293.tar.bz2
gentoo-805d270a2d2ef1096d73ddc94a4d81dbf9005293.zip
app-vim/vimagit: version bump to 1.7.2
Diffstat (limited to 'app-vim/vimagit/vimagit-1.7.2.ebuild')
-rw-r--r--app-vim/vimagit/vimagit-1.7.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-vim/vimagit/vimagit-1.7.2.ebuild b/app-vim/vimagit/vimagit-1.7.2.ebuild
new file mode 100644
index 000000000000..5e291f76fe70
--- /dev/null
+++ b/app-vim/vimagit/vimagit-1.7.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit vim-plugin
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/jreybert/vimagit.git"
+else
+ SRC_URI="https://github.com/jreybert/vimagit/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="vim plugin: ease your git workflow within vim"
+HOMEPAGE="https://github.com/jreybert/vimagit"
+LICENSE="vim"
+VIM_PLUGIN_HELPFILES="${PN}"
+
+RDEPEND="dev-vcs/git"
+
+src_prepare() {
+ rm _config.yml || die
+ default
+}