summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-03-07 05:57:53 -0500
committerTim Harder <radhermit@gentoo.org>2017-03-07 05:59:54 -0500
commitf1a7597c991331106308faecb7905191bfdf41d6 (patch)
tree1b48f9e0a059240e6a293317f6b2440765563b01 /app-vim/vimagit
parentmail-client/kube: add missing dependencies (diff)
downloadgentoo-f1a7597c991331106308faecb7905191bfdf41d6.tar.gz
gentoo-f1a7597c991331106308faecb7905191bfdf41d6.tar.bz2
gentoo-f1a7597c991331106308faecb7905191bfdf41d6.zip
app-vim/vimagit: initial import
Diffstat (limited to 'app-vim/vimagit')
-rw-r--r--app-vim/vimagit/Manifest1
-rw-r--r--app-vim/vimagit/metadata.xml11
-rw-r--r--app-vim/vimagit/vimagit-1.7.1.ebuild20
-rw-r--r--app-vim/vimagit/vimagit-9999.ebuild20
4 files changed, 52 insertions, 0 deletions
diff --git a/app-vim/vimagit/Manifest b/app-vim/vimagit/Manifest
new file mode 100644
index 000000000000..4c24c28e67cd
--- /dev/null
+++ b/app-vim/vimagit/Manifest
@@ -0,0 +1 @@
+DIST vimagit-1.7.1.tar.gz 35302 SHA256 96b61af002f31f1a73bb67ced06e8aced696e6c9539f0d5be9f25c469f1a16c4 SHA512 8ce2959c135da90b880ccdcd66e71661c7908f250d47a24ede025762a6e9422cebcf8fd516bf99e475605f4278e232713c66293781ceb95f47a22031e9260a71 WHIRLPOOL 8331ab3736017b8930934e8661002edf3d24efe92032f7e0656338ae44f21b02037a9673f91e6733b4ef09b15a75b413419b91a656a54224317d5aba24aa1f9d
diff --git a/app-vim/vimagit/metadata.xml b/app-vim/vimagit/metadata.xml
new file mode 100644
index 000000000000..5b153f66c473
--- /dev/null
+++ b/app-vim/vimagit/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">jreybert/vimagit</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-vim/vimagit/vimagit-1.7.1.ebuild b/app-vim/vimagit/vimagit-1.7.1.ebuild
new file mode 100644
index 000000000000..1583759b0cc2
--- /dev/null
+++ b/app-vim/vimagit/vimagit-1.7.1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit vim-plugin
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/jreybert/vimagit.git"
+else
+ SRC_URI="https://github.com/jreybert/vimagit/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="vim plugin: ease your git workflow within vim"
+HOMEPAGE="https://github.com/jreybert/vimagit"
+LICENSE="vim"
+VIM_PLUGIN_HELPFILES="${PN}"
+
+RDEPEND="dev-vcs/git"
diff --git a/app-vim/vimagit/vimagit-9999.ebuild b/app-vim/vimagit/vimagit-9999.ebuild
new file mode 100644
index 000000000000..1583759b0cc2
--- /dev/null
+++ b/app-vim/vimagit/vimagit-9999.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit vim-plugin
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/jreybert/vimagit.git"
+else
+ SRC_URI="https://github.com/jreybert/vimagit/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="vim plugin: ease your git workflow within vim"
+HOMEPAGE="https://github.com/jreybert/vimagit"
+LICENSE="vim"
+VIM_PLUGIN_HELPFILES="${PN}"
+
+RDEPEND="dev-vcs/git"