summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-04-24 11:12:16 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-04-24 11:12:16 -0700
commitfcd3042cc804898941beb3083bd385ea54c2f01b (patch)
tree37da544b315754d72bcdf6a1b36d982f56a025e3 /app-vim/vimpython
parentdev-lang/yasm: EAPI=7 (diff)
downloadgentoo-fcd3042cc804898941beb3083bd385ea54c2f01b.tar.gz
gentoo-fcd3042cc804898941beb3083bd385ea54c2f01b.tar.bz2
gentoo-fcd3042cc804898941beb3083bd385ea54c2f01b.zip
app-vim/vimpython-1.13-r3: revbump, move to eapi=7, add py3{7,8}
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'app-vim/vimpython')
-rw-r--r--app-vim/vimpython/vimpython-1.13-r3.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/app-vim/vimpython/vimpython-1.13-r3.ebuild b/app-vim/vimpython/vimpython-1.13-r3.ebuild
new file mode 100644
index 000000000000..9f704f796ebc
--- /dev/null
+++ b/app-vim/vimpython/vimpython-1.13-r3.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{6,7,8}} )
+
+inherit vim-plugin python-single-r1
+
+DESCRIPTION="vim plugin: A set of menus/shortcuts to work with Python files"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=30"
+LICENSE="vim"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="app-arch/unzip"
+RDEPEND="${PYTHON_DEPS}"