summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-07 13:19:23 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-09 17:17:39 +0100
commit2f385a3f4c369e74e723ebffc5d229fa9c53379a (patch)
treee4b854b22d796904a02339b2bbed3fc18eba2a24 /app-vim/voom/voom-5.3-r1.ebuild
parentapp-vim/vimpress: Switch to PYTHON_MULTI_USEDEP API (diff)
downloadgentoo-2f385a3f4c369e74e723ebffc5d229fa9c53379a.tar.gz
gentoo-2f385a3f4c369e74e723ebffc5d229fa9c53379a.tar.bz2
gentoo-2f385a3f4c369e74e723ebffc5d229fa9c53379a.zip
app-vim/voom: Switch to PYTHON_MULTI_USEDEP API
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-vim/voom/voom-5.3-r1.ebuild')
-rw-r--r--app-vim/voom/voom-5.3-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-vim/voom/voom-5.3-r1.ebuild b/app-vim/voom/voom-5.3-r1.ebuild
new file mode 100644
index 000000000000..af13fa790883
--- /dev/null
+++ b/app-vim/voom/voom-5.3-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit python-single-r1 vim-plugin
+
+DESCRIPTION="vim plugin: emulates a two-pane text outliner"
+HOMEPAGE="https://vim-voom.github.com/ https://www.vim.org/scripts/script.php?script_id=2657"
+SRC_URI="https://github.com/vim-voom/VOoM/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="CC0-1.0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+RDEPEND="${PYTHON_DEPS}
+ || (
+ app-editors/vim[python,${PYTHON_SINGLE_USEDEP}]
+ app-editors/gvim[python,${PYTHON_SINGLE_USEDEP}]
+ )"
+
+S=${WORKDIR}/VOoM-${PV}