summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2020-01-30 20:45:23 -0700
committerTim Harder <radhermit@gentoo.org>2020-01-30 20:49:48 -0700
commit017a1f4f4de3b56406f693461cc143f358e01389 (patch)
tree166ab86d6128ea5adba095f4b39232a71c319724 /app-vim
parentmedia-libs/simage: removed unused patches (diff)
downloadgentoo-017a1f4f4de3b56406f693461cc143f358e01389.tar.gz
gentoo-017a1f4f4de3b56406f693461cc143f358e01389.tar.bz2
gentoo-017a1f4f4de3b56406f693461cc143f358e01389.zip
app-vim/merginal: version bump to 2.1.2
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/merginal/Manifest1
-rw-r--r--app-vim/merginal/merginal-2.1.2.ebuild31
-rw-r--r--app-vim/merginal/merginal-9999.ebuild4
3 files changed, 34 insertions, 2 deletions
diff --git a/app-vim/merginal/Manifest b/app-vim/merginal/Manifest
index 137e14b70a3d..f726ade47058 100644
--- a/app-vim/merginal/Manifest
+++ b/app-vim/merginal/Manifest
@@ -1 +1,2 @@
DIST merginal-2.1.0.tar.gz 13510 BLAKE2B c44f3873f36ee540e69f1cd87558e2601f944f430d15ae0e863adbba5383637ddbae2bee01cf1f7788f677a159da7870a83b909562813f8817d610e85f9d4a96 SHA512 3514c210a016d3446e73b7acc8a8a4cc2427e0133df81d7c644aaa1465e9c5945d3f46b7cac697f70cac990563e595305360991cdaa8244032167aea5f88eaed
+DIST merginal-2.1.2.tar.gz 15156 BLAKE2B a8181ebd7aa67663b4541b5cb5028b6cadcca68c48f325dca07308ad13554d1d4b96b53f0a30e516cea732c880e68cb7e4cb7836b72cbd6b59a009e8d3c744b2 SHA512 70da5529ee22b3f06d83ecac62634d46d30472f064613a1844a7cdae31ed97366b5fcf6b31f4becd4cde246ccac32be6528c8c93ee2f02bdd32932388282f9bf
diff --git a/app-vim/merginal/merginal-2.1.2.ebuild b/app-vim/merginal/merginal-2.1.2.ebuild
new file mode 100644
index 000000000000..6d95e33ef108
--- /dev/null
+++ b/app-vim/merginal/merginal-2.1.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vim-plugin
+
+MY_PN=vim-${PN}
+MY_P=${MY_PN}-${PV}
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/idanarye/${MY_PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/idanarye/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+DESCRIPTION="vim script: fugitive extension to manage and merge git branches"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=4955 https://github.com/idanarye/vim-merginal/"
+LICENSE="vim"
+
+RDEPEND="app-vim/fugitive"
+
+VIM_PLUGIN_HELPFILES="${PN}"
+
+src_prepare() {
+ rm README.md || die
+ default
+}
diff --git a/app-vim/merginal/merginal-9999.ebuild b/app-vim/merginal/merginal-9999.ebuild
index fbe6b96d4612..6d95e33ef108 100644
--- a/app-vim/merginal/merginal-9999.ebuild
+++ b/app-vim/merginal/merginal-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit vim-plugin