summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-06-16 22:01:32 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-06-16 22:02:03 +0200
commit7634836b4ba252351342e98e76274bc1637873f9 (patch)
treea4d2c212313c5cbe9fa618c6f288030f51025ca1 /app-vim
parentdev-python/pdb-clone: new package. (diff)
downloadgentoo-7634836b4ba252351342e98e76274bc1637873f9.tar.gz
gentoo-7634836b4ba252351342e98e76274bc1637873f9.tar.bz2
gentoo-7634836b4ba252351342e98e76274bc1637873f9.zip
app-vim/pyclewn: add missing dependency on pdb-clone.
Closes: https://bugs.gentoo.org/619340 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/pyclewn/pyclewn-2.1-r1.ebuild19
1 files changed, 12 insertions, 7 deletions
diff --git a/app-vim/pyclewn/pyclewn-2.1-r1.ebuild b/app-vim/pyclewn/pyclewn-2.1-r1.ebuild
index f21226086046..63b9b959aa2b 100644
--- a/app-vim/pyclewn/pyclewn-2.1-r1.ebuild
+++ b/app-vim/pyclewn/pyclewn-2.1-r1.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
inherit eutils vim-plugin distutils-r1
SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
@@ -17,13 +18,17 @@ CDEPEND="|| (
>=app-editors/vim-7.3
>=app-editors/gvim-7.3[netbeans]
)"
-DEPEND="${CDEPEND}
- app-arch/vimball
-"
-RDEPEND="${DEPEND}
+
+DEPEND="
+ ${CDEPEND}
+ app-arch/vimball"
+
+RDEPEND="
+ ${DEPEND}
+ $(python_gen_cond_dep \
+ 'dev-python/pdb-clone[${PYTHON_USEDEP}]' python{2_7,3_5})
$(python_gen_cond_dep \
- 'dev-python/trollius[${PYTHON_USEDEP}]' python{2_7,3_3})
-"
+ 'dev-python/trollius[${PYTHON_USEDEP}]' python{2_7,3_3})"
SLOT="0"