summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-01 01:50:40 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-01 01:50:40 +0100
commit8b55ca4738e0eddea0f12b1faefb673fa4b5f4be (patch)
treeb1c8fe1cf89f0b1322c2fea5953841459818207d /app-vim
parentapp-vim/vim-latex: Remove old (py3.6) (diff)
downloadgentoo-8b55ca4738e0eddea0f12b1faefb673fa4b5f4be.tar.gz
gentoo-8b55ca4738e0eddea0f12b1faefb673fa4b5f4be.tar.bz2
gentoo-8b55ca4738e0eddea0f12b1faefb673fa4b5f4be.zip
app-vim/vimoutliner: Remove old (py3.6)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/vimoutliner/files/vimoutliner-0.3.6-fix-shebangs.patch21
-rw-r--r--app-vim/vimoutliner/vimoutliner-0.3.6-r3.ebuild51
2 files changed, 0 insertions, 72 deletions
diff --git a/app-vim/vimoutliner/files/vimoutliner-0.3.6-fix-shebangs.patch b/app-vim/vimoutliner/files/vimoutliner-0.3.6-fix-shebangs.patch
deleted file mode 100644
index a363d96b34f6..000000000000
--- a/app-vim/vimoutliner/files/vimoutliner-0.3.6-fix-shebangs.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- a/vimoutliner/scripts/outline_freemind/outline_freemind.py 2017-08-24 21:20:25.138762046 +0000
-+++ b/vimoutliner/scripts/outline_freemind/outline_freemind.py 2017-08-24 21:20:34.484797791 +0000
-@@ -1,3 +1,4 @@
-+#!/usr/bin/python
- '''Read in an otl file and generate an xml mind map viewable in freemind
-
- Make sure that you check that round trip on your file works.
---- a/vimoutliner/scripts/outline_freemind/otl.py 2017-08-24 21:23:08.194385573 +0000
-+++ b/vimoutliner/scripts/outline_freemind/otl.py 2017-08-24 21:23:14.756410662 +0000
-@@ -1,3 +1,4 @@
-+#!/usr/bin/python
- # Some integer IDs
- # headings are 1, 2, 3, ....
- bodynowrap = -1 # ;
---- a/vimoutliner/scripts/outline_freemind/freemind_outline.py 2017-08-25 08:07:01.985459421 +0000
-+++ b/vimoutliner/scripts/outline_freemind/freemind_outline.py 2017-08-25 08:07:11.244502161 +0000
-@@ -1,3 +1,4 @@
-+#!/usr/bin/python
- '''Converts a freemind xml .mm file to an outline file compatable with vim
- outliner.
-
diff --git a/app-vim/vimoutliner/vimoutliner-0.3.6-r3.ebuild b/app-vim/vimoutliner/vimoutliner-0.3.6-r3.ebuild
deleted file mode 100644
index 4bea6a6dc884..000000000000
--- a/app-vim/vimoutliner/vimoutliner-0.3.6-r3.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit vim-plugin python-single-r1
-
-DESCRIPTION="vim plugin: easy and fast outlining"
-HOMEPAGE="https://github.com/vimoutliner/vimoutliner"
-SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-VIM_PLUGIN_HELPFILES="vimoutliner"
-VIM_PLUGIN_MESSAGES="filetype"
-
-PATCHES=( "${FILESDIR}/${P}-fix-shebangs.patch" )
-
-RDEPEND="${PYTHON_DEPS}
- $(python_gen_cond_dep '
- dev-python/autopep8[${PYTHON_MULTI_USEDEP}]
- ')"
-
-pkg_setup() {
- python-single-r1_pkg_setup
-}
-
-src_prepare() {
- default
- sed -i -e '/^if exists/,/endif/d' ftdetect/vo_base.vim || die
- sed -i -e 's/g:vo_modules2load/g:vo_modules_load/' vimoutliner/vimoutlinerrc || die
- rm -v install.sh || die
- find "${S}" -type f -exec chmod a+r {} \; || die
-}
-
-src_compile() {
- local pyscript _pyscript
- for pyscript in $(find "${S}" -type f -name \*.py); do
- _pyscript=$(basename "${pyscript}")
- einfo "Processing ${_pyscript}"
- sed -i -e 's#[ \t]*$##g;' "${pyscript}" || die
- 2to3 --no-diffs -w -n "${pyscript}" 2> /dev/null || die
- autopep8 -i "${pyscript}" || die
- python_fix_shebang -q "${pyscript}" || die
- eend $?
- done
-}