summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Bracht Laumann Jespersen <t@laumann.xyz>2022-05-30 16:43:02 +0200
committerSam James <sam@gentoo.org>2022-06-01 00:46:05 +0100
commit8c659f037944be911121b4c4e43ff06aa3316ecf (patch)
tree2cae490325e1f1747e9b92b898567c8de3664d3f /app-vim
parentdev-java/commons-daemon: do not call ar directly (diff)
downloadgentoo-8c659f037944be911121b4c4e43ff06aa3316ecf.tar.gz
gentoo-8c659f037944be911121b4c4e43ff06aa3316ecf.tar.bz2
gentoo-8c659f037944be911121b4c4e43ff06aa3316ecf.zip
app-vim/gitgutter: add 20220524
Bug: https://bugs.gentoo.org/830867 Signed-off-by: Thomas Bracht Laumann Jespersen <t@laumann.xyz> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/gitgutter/Manifest1
-rw-r--r--app-vim/gitgutter/gitgutter-20220524.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/app-vim/gitgutter/Manifest b/app-vim/gitgutter/Manifest
index 212b80f5d342..c984b9c0c039 100644
--- a/app-vim/gitgutter/Manifest
+++ b/app-vim/gitgutter/Manifest
@@ -1,2 +1,3 @@
DIST gitgutter-20180316.tar.gz 46344 BLAKE2B f981753a0f8d066b7cb5c16c49cfdd1a1aac1c6623b4645b8b1abd5719470ac181e09c8b736f8b8a14e6098b60cb8f97b114dc5c2a587b6d1875fcf27b4b12cf SHA512 15873b2cccc49f8aec9de312efedc615d6fa822b45ca8ce53cc6cc878fcaf3a6ab3f02eb5d082ff329528cce1b48358846b0aba3f9d3bc8aadd29aa57d3b1a30
DIST gitgutter-20180815.tar.gz 46741 BLAKE2B 85189390a2d8c5feaf8d2fabfd2c72bf79954fd1e9f2c3ffeca748e84caf13924f71ef5837ab62aef0ae003a01304305e73bbcb12dca27294c8164e960249fec SHA512 b6d3bd0f779d9afbd38df33888ab3ee0f1d8d10de0a6c5c6766f7f73a292cdd589a6774faa2871877075f6cedd29f14bba07c9a769d706e0e67d8817db86cfaa
+DIST gitgutter-20220524.tar.gz 46741 BLAKE2B 85189390a2d8c5feaf8d2fabfd2c72bf79954fd1e9f2c3ffeca748e84caf13924f71ef5837ab62aef0ae003a01304305e73bbcb12dca27294c8164e960249fec SHA512 b6d3bd0f779d9afbd38df33888ab3ee0f1d8d10de0a6c5c6766f7f73a292cdd589a6774faa2871877075f6cedd29f14bba07c9a769d706e0e67d8817db86cfaa
diff --git a/app-vim/gitgutter/gitgutter-20220524.ebuild b/app-vim/gitgutter/gitgutter-20220524.ebuild
new file mode 100644
index 000000000000..257b0db9bd08
--- /dev/null
+++ b/app-vim/gitgutter/gitgutter-20220524.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit vim-plugin
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/airblade/vim-gitgutter.git"
+ inherit git-r3
+else
+ inherit vcs-snapshot
+ COMMIT_HASH="ded11946c04aeab5526f869174044019ae9e3c32"
+ SRC_URI="https://github.com/airblade/vim-gitgutter/archive/${COMMIT_HASH}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="vim plugin: shows a git diff in the sign column and stages/reverts hunks"
+HOMEPAGE="https://github.com/airblade/vim-gitgutter/"
+LICENSE="MIT"
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+RDEPEND="dev-vcs/git"
+
+src_prepare() {
+ default
+
+ # remove unwanted test dir
+ rm -r test || die
+}