summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-03-19 17:46:13 +0100
committerConrad Kostecki <conikost@gentoo.org>2023-09-14 23:22:43 +0200
commit9c898f0ffddb695d38afffd98393bde37d9a2fff (patch)
tree751fe8594acb91e3acf7228364c282d7335ef7fd /app-vim
parentapp-vim/pdv: EAPI8 bump (diff)
downloadgentoo-9c898f0ffddb695d38afffd98393bde37d9a2fff.tar.gz
gentoo-9c898f0ffddb695d38afffd98393bde37d9a2fff.tar.bz2
gentoo-9c898f0ffddb695d38afffd98393bde37d9a2fff.zip
app-vim/perlomni: EAPI8 bump
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/perlomni/perlomni-2.5-r1.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/app-vim/perlomni/perlomni-2.5-r1.ebuild b/app-vim/perlomni/perlomni-2.5-r1.ebuild
new file mode 100644
index 000000000000..fbaa53b23584
--- /dev/null
+++ b/app-vim/perlomni/perlomni-2.5-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: a vim plugin with Perl omni completion functions"
+HOMEPAGE="https://github.com/c9s/perlomni.vim"
+SRC_URI="https://github.com/c9s/${PN}.vim/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}.vim-${PV}"
+
+LICENSE="vim.org"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+DEPEND="dev-lang/perl"
+RDEPEND="${DEPEND}"
+
+src_compile() { :; }