summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-27 09:11:02 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-27 09:16:31 +0100
commita32306a0025d4fc7036b59dd88c34a62af372ebb (patch)
tree7557794004a5814532da2d1f066dfb75b238df87 /app-vim
parentapp-office/gnucash: x86 stable wrt bug #677938 (diff)
downloadgentoo-a32306a0025d4fc7036b59dd88c34a62af372ebb.tar.gz
gentoo-a32306a0025d4fc7036b59dd88c34a62af372ebb.tar.bz2
gentoo-a32306a0025d4fc7036b59dd88c34a62af372ebb.zip
app-vim/gentoo-syntax: Bump to 20191127
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/gentoo-syntax/Manifest1
-rw-r--r--app-vim/gentoo-syntax/gentoo-syntax-20191127.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-vim/gentoo-syntax/Manifest b/app-vim/gentoo-syntax/Manifest
index 6c8121ed5ebc..9529453f751b 100644
--- a/app-vim/gentoo-syntax/Manifest
+++ b/app-vim/gentoo-syntax/Manifest
@@ -1 +1,2 @@
DIST gentoo-syntax-20190609.tar.bz2 18401 BLAKE2B db738540fc85d8edd0269ade33e174db08b9231237f1138da9a3f6ecff7c188a041b312975629be652a5384d0c914ad8d7a3ac5ef14670e4bc0859fbdf3dcbc7 SHA512 70fbf6e37eee2e5b007eb59b76492f41046884a8310a6074ca5fbab666ec74d46ab3e57bbf2ae784db2e17bfd1c4801b18b71cf37f746e02ff640de1f6821ec7
+DIST gentoo-syntax-20191127.tar.bz2 18635 BLAKE2B 79db829602df5795e32c44db71e28cfcda06ef014e9d5e5cf47d6f7fcb0b054c46caef1bb594c4fceae318df8a8cd0c6a619771ae5438eb21deed530842ce53d SHA512 654b69cf55719b9c254c376364f404c393189ec70d7b8a9284349774e00118fb636dbfefa86eb57220a49a5a7324e9f0484879d69afb199bb1c8ae7f0b5e591e
diff --git a/app-vim/gentoo-syntax/gentoo-syntax-20191127.ebuild b/app-vim/gentoo-syntax/gentoo-syntax-20191127.ebuild
new file mode 100644
index 000000000000..9ab8c1f38389
--- /dev/null
+++ b/app-vim/gentoo-syntax/gentoo-syntax-20191127.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Gentoo and Portage syntax highlighting"
+HOMEPAGE="https://github.com/gentoo/gentoo-syntax"
+SRC_URI="https://gitweb.gentoo.org/proj/gentoo-syntax.git/snapshot/${P}.tar.bz2"
+
+LICENSE="vim"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="ignore-glep31"
+
+VIM_PLUGIN_HELPFILES="gentoo-syntax"
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_prepare() {
+ default
+ if use ignore-glep31 ; then
+ for f in ftplugin/*.vim ; do
+ ebegin "Removing UTF-8 rules from ${f} ..."
+ sed -i -e 's~\(setlocal fileencoding=utf-8\)~" \1~' ${f} \
+ || die "waah! bad sed voodoo. need more goats."
+ eend $?
+ done
+ fi
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ if use ignore-glep31 1>/dev/null ; then
+ ewarn "You have chosen to disable the rules which ensure GLEP 31"
+ ewarn "compliance. When editing ebuilds, please make sure you get"
+ ewarn "the character set correct."
+ fi
+ fi
+}