summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-07 13:18:10 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-09 17:17:36 +0100
commitb4b479e4effc6a93fcea8a98ae6f03fa99f7be49 (patch)
tree9efd00f8b3961809b2504f8df78c7b45dc5c08da /app-vim
parentapp-vim/vimcalc: Switch to PYTHON_SINGLE_USEDEP (diff)
downloadgentoo-b4b479e4effc6a93fcea8a98ae6f03fa99f7be49.tar.gz
gentoo-b4b479e4effc6a93fcea8a98ae6f03fa99f7be49.tar.bz2
gentoo-b4b479e4effc6a93fcea8a98ae6f03fa99f7be49.zip
app-vim/vimoutliner: Switch to PYTHON_MULTI_USEDEP API
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/vimoutliner/vimoutliner-0.3.6-r3.ebuild (renamed from app-vim/vimoutliner/vimoutliner-0.3.6-r2.ebuild)4
-rw-r--r--app-vim/vimoutliner/vimoutliner-0.4.0_p20180301-r2.ebuild (renamed from app-vim/vimoutliner/vimoutliner-0.4.0_p20180301-r1.ebuild)6
2 files changed, 7 insertions, 3 deletions
diff --git a/app-vim/vimoutliner/vimoutliner-0.3.6-r2.ebuild b/app-vim/vimoutliner/vimoutliner-0.3.6-r3.ebuild
index 4168f3a1c1b7..517d6a36c565 100644
--- a/app-vim/vimoutliner/vimoutliner-0.3.6-r2.ebuild
+++ b/app-vim/vimoutliner/vimoutliner-0.3.6-r3.ebuild
@@ -21,7 +21,9 @@ VIM_PLUGIN_MESSAGES="filetype"
PATCHES=( "${FILESDIR}/${P}-fix-shebangs.patch" )
RDEPEND="${PYTHON_DEPS}
- dev-python/autopep8[${PYTHON_USEDEP}]"
+ $(python_gen_cond_dep '
+ dev-python/autopep8[${PYTHON_MULTI_USEDEP}]
+ ')"
pkg_setup() {
python-single-r1_pkg_setup
diff --git a/app-vim/vimoutliner/vimoutliner-0.4.0_p20180301-r1.ebuild b/app-vim/vimoutliner/vimoutliner-0.4.0_p20180301-r2.ebuild
index 91f8bce967ca..c6da5e2e298a 100644
--- a/app-vim/vimoutliner/vimoutliner-0.4.0_p20180301-r1.ebuild
+++ b/app-vim/vimoutliner/vimoutliner-0.4.0_p20180301-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -23,7 +23,9 @@ VIM_PLUGIN_HELPFILES="vimoutliner"
VIM_PLUGIN_MESSAGES="filetype"
RDEPEND="${PYTHON_DEPS}
- dev-python/autopep8[${PYTHON_USEDEP}]"
+ $(python_gen_cond_dep '
+ dev-python/autopep8[${PYTHON_MULTI_USEDEP}]
+ ')"
DEPEND="${RDEPEND}"
src_prepare() {