summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-01-14 21:38:17 +0100
committerPatrice Clement <monsieurp@gentoo.org>2018-01-14 21:38:37 +0100
commitce41e6b061931d785d463567811352083dbba8d4 (patch)
treeba380a2f3ee7d83ba5265bb7711e5908c4f3994c /app-vim
parentsys-devel/gcc-config: mark 1.8-r1 arm64/m68k/s390/sh stable (diff)
downloadgentoo-ce41e6b061931d785d463567811352083dbba8d4.tar.gz
gentoo-ce41e6b061931d785d463567811352083dbba8d4.tar.bz2
gentoo-ce41e6b061931d785d463567811352083dbba8d4.zip
app-vim/haskellmode: new ebuild.
The Haskell mode plugins provide advanced support for Haskell development using GHC/GHCi. Closes: https://bugs.gentoo.org/513730 Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/haskellmode/Manifest1
-rw-r--r--app-vim/haskellmode/haskellmode-20101118-r1.ebuild50
-rw-r--r--app-vim/haskellmode/metadata.xml8
3 files changed, 59 insertions, 0 deletions
diff --git a/app-vim/haskellmode/Manifest b/app-vim/haskellmode/Manifest
new file mode 100644
index 000000000000..2115ed15edf6
--- /dev/null
+++ b/app-vim/haskellmode/Manifest
@@ -0,0 +1 @@
+DIST haskellmode-20101118.tar.bz2 21637 BLAKE2B f64278a4d6d892068d1de85b0d19892908a5b841485cde2af419777637db353364882af76a84e406bd01c5f9d8967ef43b44edb5e40ec6b2762aa6d97975045b SHA512 c1882766c08afeda9aea9ddd072e6107f5615ee5a0916d029170ad38097a2fa7dce72bc2429618ac3889afb8d1de9ab53ddaf5beff45f873f9eb5a57b04bc6aa
diff --git a/app-vim/haskellmode/haskellmode-20101118-r1.ebuild b/app-vim/haskellmode/haskellmode-20101118-r1.ebuild
new file mode 100644
index 000000000000..00f065cc2c85
--- /dev/null
+++ b/app-vim/haskellmode/haskellmode-20101118-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VIM_PLUGIN_VIM_VERSION="7.1"
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Provides IDE-like features for Haskell development"
+HOMEPAGE="http://projects.haskell.org/haskellmode-vim"
+SRC_URI="http://code.haskell.org/~wwolff/haskellmode/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT=0
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ ${RDEPEND}"
+
+RDEPEND="
+ dev-lang/ghc[doc]
+ net-misc/wget"
+
+VIM_PLUGIN_HELPFILES="haskellmode"
+VIM_PLUGIN_MESSAGES="filetype"
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+
+ elog "You must set 'g:haddock_browser' to the path of your preferred browser, and"
+ elog "depending on your setup you may also want to change the default value of"
+ elog "'g:haddock_browser_callformat' (see ':help g:haddock_browser_callformat' for"
+ elog "full usage info). You can persist these settings in your vimrc file, for"
+ elog "example:"
+ elog
+ elog " let g:haddock_browser=\"/usr/bin/elinks\""
+ elog " let g:haddock_browser_callformat=\"%s file://%s >/dev/null 2>&1 &\""
+ elog
+ elog "To enable GHC compiler integration, also add the following to your vimrc:"
+ elog
+ elog " au BufEnter *.hs compiler ghc"
+ elog
+ elog "The first time you load haskellmode, you must generate a Haddock index. Do"
+ elog "this with the command:"
+ elog
+ elog " :ExportDocIndex"
+ elog
+ elog "Consult ${HOMEPAGE} for further setup and usage information."
+}
diff --git a/app-vim/haskellmode/metadata.xml b/app-vim/haskellmode/metadata.xml
new file mode 100644
index 000000000000..5c000c763084
--- /dev/null
+++ b/app-vim/haskellmode/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+</pkgmetadata>