summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-22 11:13:48 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-22 11:25:12 +0200
commite419e962046e8d82749427bd9882fb43c2952e97 (patch)
treed3da9011e28fbeb15d8403cf09ae74261ff0d359 /app-vim
parentapp-vim/jedi: Add missing PYTHON_{DEPS,REQUIRED_USE} (diff)
downloadgentoo-e419e962046e8d82749427bd9882fb43c2952e97.tar.gz
gentoo-e419e962046e8d82749427bd9882fb43c2952e97.tar.bz2
gentoo-e419e962046e8d82749427bd9882fb43c2952e97.zip
app-vim/vimoutliner: Add missing PYTHON_DEPS
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/vimoutliner/vimoutliner-0.3.6-r1.ebuild31
-rw-r--r--app-vim/vimoutliner/vimoutliner-0.3.6-r2.ebuild49
-rw-r--r--app-vim/vimoutliner/vimoutliner-0.3.6.ebuild23
-rw-r--r--app-vim/vimoutliner/vimoutliner-0.4.0_p20180301-r1.ebuild (renamed from app-vim/vimoutliner/vimoutliner-0.4.0_p20180301.ebuild)7
4 files changed, 56 insertions, 54 deletions
diff --git a/app-vim/vimoutliner/vimoutliner-0.3.6-r1.ebuild b/app-vim/vimoutliner/vimoutliner-0.3.6-r1.ebuild
index d7c15479021b..36ebfb95a0a7 100644
--- a/app-vim/vimoutliner/vimoutliner-0.3.6-r1.ebuild
+++ b/app-vim/vimoutliner/vimoutliner-0.3.6-r1.ebuild
@@ -1,31 +1,19 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
-
-inherit vim-plugin python-single-r1
+inherit vim-plugin
DESCRIPTION="vim plugin: easy and fast outlining"
HOMEPAGE="https://github.com/vimoutliner/vimoutliner"
SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.zip -> ${P}.zip"
LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+KEYWORDS="alpha amd64 ia64 ~mips ppc sparc x86"
VIM_PLUGIN_HELPFILES="vimoutliner"
VIM_PLUGIN_MESSAGES="filetype"
-PATCHES=( "${FILESDIR}/${P}-fix-shebangs.patch" )
-
-RDEPEND="dev-python/autopep8"
-
-pkg_setup() {
- python-single-r1_pkg_setup
-}
-
src_prepare() {
default
sed -i -e '/^if exists/,/endif/d' ftdetect/vo_base.vim || die
@@ -33,16 +21,3 @@ src_prepare() {
rm -v install.sh || die
find "${S}" -type f -exec chmod a+r {} \; || die
}
-
-src_compile() {
- local pyscript _pyscript
- for pyscript in $(find "${S}" -type f -name \*.py); do
- _pyscript=$(basename "${pyscript}")
- einfo "Processing ${_pyscript}"
- sed -i -e 's#[ \t]*$##g;' "${pyscript}" || die
- 2to3 --no-diffs -w -n "${pyscript}" 2> /dev/null || die
- autopep8 -i "${pyscript}" || die
- python_fix_shebang -q "${pyscript}" || die
- eend $?
- done
-}
diff --git a/app-vim/vimoutliner/vimoutliner-0.3.6-r2.ebuild b/app-vim/vimoutliner/vimoutliner-0.3.6-r2.ebuild
new file mode 100644
index 000000000000..b9d58e98e883
--- /dev/null
+++ b/app-vim/vimoutliner/vimoutliner-0.3.6-r2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+
+inherit vim-plugin python-single-r1
+
+DESCRIPTION="vim plugin: easy and fast outlining"
+HOMEPAGE="https://github.com/vimoutliner/vimoutliner"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.zip -> ${P}.zip"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+VIM_PLUGIN_HELPFILES="vimoutliner"
+VIM_PLUGIN_MESSAGES="filetype"
+
+PATCHES=( "${FILESDIR}/${P}-fix-shebangs.patch" )
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/autopep8[${PYTHON_USEDEP}]"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ sed -i -e '/^if exists/,/endif/d' ftdetect/vo_base.vim || die
+ sed -i -e 's/g:vo_modules2load/g:vo_modules_load/' vimoutliner/vimoutlinerrc || die
+ rm -v install.sh || die
+ find "${S}" -type f -exec chmod a+r {} \; || die
+}
+
+src_compile() {
+ local pyscript _pyscript
+ for pyscript in $(find "${S}" -type f -name \*.py); do
+ _pyscript=$(basename "${pyscript}")
+ einfo "Processing ${_pyscript}"
+ sed -i -e 's#[ \t]*$##g;' "${pyscript}" || die
+ 2to3 --no-diffs -w -n "${pyscript}" 2> /dev/null || die
+ autopep8 -i "${pyscript}" || die
+ python_fix_shebang -q "${pyscript}" || die
+ eend $?
+ done
+}
diff --git a/app-vim/vimoutliner/vimoutliner-0.3.6.ebuild b/app-vim/vimoutliner/vimoutliner-0.3.6.ebuild
deleted file mode 100644
index 36ebfb95a0a7..000000000000
--- a/app-vim/vimoutliner/vimoutliner-0.3.6.ebuild
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit vim-plugin
-
-DESCRIPTION="vim plugin: easy and fast outlining"
-HOMEPAGE="https://github.com/vimoutliner/vimoutliner"
-SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.zip -> ${P}.zip"
-LICENSE="GPL-2"
-KEYWORDS="alpha amd64 ia64 ~mips ppc sparc x86"
-
-VIM_PLUGIN_HELPFILES="vimoutliner"
-VIM_PLUGIN_MESSAGES="filetype"
-
-src_prepare() {
- default
- sed -i -e '/^if exists/,/endif/d' ftdetect/vo_base.vim || die
- sed -i -e 's/g:vo_modules2load/g:vo_modules_load/' vimoutliner/vimoutlinerrc || die
- rm -v install.sh || die
- find "${S}" -type f -exec chmod a+r {} \; || die
-}
diff --git a/app-vim/vimoutliner/vimoutliner-0.4.0_p20180301.ebuild b/app-vim/vimoutliner/vimoutliner-0.4.0_p20180301-r1.ebuild
index 693542279762..91f8bce967ca 100644
--- a/app-vim/vimoutliner/vimoutliner-0.4.0_p20180301.ebuild
+++ b/app-vim/vimoutliner/vimoutliner-0.4.0_p20180301-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -22,13 +22,14 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
VIM_PLUGIN_HELPFILES="vimoutliner"
VIM_PLUGIN_MESSAGES="filetype"
-RDEPEND="dev-python/autopep8"
+RDEPEND="${PYTHON_DEPS}
+ dev-python/autopep8[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}"
src_prepare() {
default
- sed -i -e '1s:^:#!/usr/bin/python\n:' vimoutliner/scripts/otl2latex/otl2latex.py
+ sed -i -e '1s:^:#!/usr/bin/python\n:' vimoutliner/scripts/otl2latex/otl2latex.py || die
find "${S}" -type f -exec chmod a+r {} \; || die
}