summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2018-09-04 09:02:02 +0200
committerUlrich Müller <ulm@gentoo.org>2018-09-04 09:02:02 +0200
commit83c3fd82a31bf0be749e1c1fb63327c2f37d84ae (patch)
tree453a9ada77c7cd7a79d734afac3a9ffdb97a7142 /app-xemacs/ebuild-mode/ebuild-mode-1.45.ebuild
parentapp-emacs/ebuild-mode: Version bump. (diff)
downloadgentoo-83c3fd82a31bf0be749e1c1fb63327c2f37d84ae.tar.gz
gentoo-83c3fd82a31bf0be749e1c1fb63327c2f37d84ae.tar.bz2
gentoo-83c3fd82a31bf0be749e1c1fb63327c2f37d84ae.zip
app-xemacs/ebuild-mode: Version bump.
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'app-xemacs/ebuild-mode/ebuild-mode-1.45.ebuild')
-rw-r--r--app-xemacs/ebuild-mode/ebuild-mode-1.45.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-xemacs/ebuild-mode/ebuild-mode-1.45.ebuild b/app-xemacs/ebuild-mode/ebuild-mode-1.45.ebuild
new file mode 100644
index 000000000000..b0e82e52e220
--- /dev/null
+++ b/app-xemacs/ebuild-mode/ebuild-mode-1.45.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xemacs-elisp
+
+DESCRIPTION="Emacs modes for editing ebuilds and other Gentoo specific files"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Emacs"
+SRC_URI="https://dev.gentoo.org/~ulm/emacs/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+
+RDEPEND=">=app-editors/xemacs-21.4.20-r5
+ app-xemacs/sh-script"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ ${XEMACS_BATCH_CLEAN} -eval "(add-to-list 'load-path \".\")" \
+ -f batch-byte-compile ebuild-mode.el gentoo-newsitem-mode.el || die
+ xemacs-elisp-make-autoload-file \
+ ebuild-mode.el gentoo-newsitem-mode.el || die
+}