summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTupone Alfredo <tupone@gentoo.org>2018-03-08 11:17:12 +0100
committerTupone Alfredo <tupone@gentoo.org>2018-03-08 11:17:35 +0100
commit4913e935f060f87c150f25dd05e50b073f7c309d (patch)
treed6913b55ba3b5188d284ef9c28215e0dd2b7b1ac /dev-ada/asis/asis-2016.ebuild
parentdev-ada/gnatcoll: Add dependency on dev-ada/xmlada (diff)
downloadgentoo-4913e935f060f87c150f25dd05e50b073f7c309d.tar.gz
gentoo-4913e935f060f87c150f25dd05e50b073f7c309d.tar.bz2
gentoo-4913e935f060f87c150f25dd05e50b073f7c309d.zip
dev-ada/asis: Require shared library for both xmlada and gnatcoll
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-ada/asis/asis-2016.ebuild')
-rw-r--r--dev-ada/asis/asis-2016.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/dev-ada/asis/asis-2016.ebuild b/dev-ada/asis/asis-2016.ebuild
index 48c6312f8b75..c54e214eb9e3 100644
--- a/dev-ada/asis/asis-2016.ebuild
+++ b/dev-ada/asis/asis-2016.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -31,10 +31,16 @@ PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
src_compile() {
emake PROCESSORS=$(makeopts_jobs)
- emake tools PROCESSORS=$(makeopts_jobs)
+ emake tools PROCESSORS=$(makeopts_jobs) \
+ GPRBUILD_FLAGS="-vl \
+ -XLIBRARY_TYPE=relocatable \
+ -XXMLADA_BUILD=relocatable"
}
src_install() {
emake prefix="${D}"/usr install
- emake prefix="${D}"/usr install-tools
+ emake prefix="${D}"/usr install-tools \
+ GPRINSTALL="gprinstall \
+ -XLIBRARY_TYPE=relocatable \
+ -XXMLADA_BUILD=relocatable"
}