summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-10-05 22:26:21 +0200
committerAlfredo Tupone <tupone@gentoo.org>2022-10-05 22:26:21 +0200
commitda72117a3e99c384babfe4db439bb5ce4bbb0855 (patch)
tree51f5752bcf420359082439893099f1167aa9ef24 /dev-ada/aunit
parentprofiles: rename clang feature to llvm, adjust parent files (diff)
downloadgentoo-da72117a3e99c384babfe4db439bb5ce4bbb0855.tar.gz
gentoo-da72117a3e99c384babfe4db439bb5ce4bbb0855.tar.bz2
gentoo-da72117a3e99c384babfe4db439bb5ce4bbb0855.zip
dev-ada/aunit: add gcc_12_2_0
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ada/aunit')
-rw-r--r--dev-ada/aunit/aunit-22.0.0.ebuild9
-rw-r--r--dev-ada/aunit/files/aunit-22.0.0-redundant.patch28
2 files changed, 34 insertions, 3 deletions
diff --git a/dev-ada/aunit/aunit-22.0.0.ebuild b/dev-ada/aunit/aunit-22.0.0.ebuild
index 78a102da278f..f4f6f8098704 100644
--- a/dev-ada/aunit/aunit-22.0.0.ebuild
+++ b/dev-ada/aunit/aunit-22.0.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-ADA_COMPAT=( gnat_202{0..1} )
+ADA_COMPAT=( gnat_202{0..1} gcc_12_2_0 )
inherit ada multiprocessing
DESCRIPTION="Ada unit testing framework"
@@ -22,7 +22,10 @@ DEPEND="${RDEPEND}
REQUIRED_USE="${ADA_REQUIRED_USE}"
-PATCHES=( "${FILESDIR}"/${PN}-2016-gentoo.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-2016-gentoo.patch
+ "${FILESDIR}"/${P}-redundant.patch
+)
src_compile() {
emake GPRBUILD="gprbuild -j$(makeopts_jobs) -v"
diff --git a/dev-ada/aunit/files/aunit-22.0.0-redundant.patch b/dev-ada/aunit/files/aunit-22.0.0-redundant.patch
new file mode 100644
index 000000000000..d22bb4a572ec
--- /dev/null
+++ b/dev-ada/aunit/files/aunit-22.0.0-redundant.patch
@@ -0,0 +1,28 @@
+From 7372e83edf47cf26dc64a49850b6fd80aaea5495 Mon Sep 17 00:00:00 2001
+From: Vasiliy Fofanov <fofanov@adacore.com>
+Date: Mon, 13 Dec 2021 18:54:17 +0100
+Subject: [PATCH] Remove redundant "with" of parent unit
+
+This fixes a warning raised by recent GNAT toolchains.
+
+TN: UC13-054
+---
+ test/src/aunit-test_suites-tests.ads | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/test/src/aunit-test_suites-tests.ads b/test/src/aunit-test_suites-tests.ads
+index 0d3ea33..377c0c3 100644
+--- a/test/src/aunit-test_suites-tests.ads
++++ b/test/src/aunit-test_suites-tests.ads
+@@ -1,10 +1,9 @@
+ --
+--- Copyright (C) 2009-2010, AdaCore
++-- Copyright (C) 2009-2021, AdaCore
+ --
+
+ with AUnit.Test_Fixtures;
+ with AUnit.Test_Results;
+-with AUnit.Test_Suites;
+
+ package AUnit.Test_Suites.Tests is
+