summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTupone Alfredo <tupone@gentoo.org>2017-12-02 22:19:31 +0100
committerTupone Alfredo <tupone@gentoo.org>2017-12-02 22:19:31 +0100
commit438f968a0513043740475474fe09818a381ad7fa (patch)
tree85e89f9da43ec58250a25b8830d66c61a53f625f /dev-ada/libgpr/libgpr-2017.ebuild
parentprofiles: drop python3_6 stable mask on amd64 (diff)
downloadgentoo-438f968a0513043740475474fe09818a381ad7fa.tar.gz
gentoo-438f968a0513043740475474fe09818a381ad7fa.tar.bz2
gentoo-438f968a0513043740475474fe09818a381ad7fa.zip
dev-ada/libgpr: splitted ebuild from deb-ada/gprbuild. Provides libs
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'dev-ada/libgpr/libgpr-2017.ebuild')
-rw-r--r--dev-ada/libgpr/libgpr-2017.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/dev-ada/libgpr/libgpr-2017.ebuild b/dev-ada/libgpr/libgpr-2017.ebuild
new file mode 100644
index 000000000000..16acad675fe9
--- /dev/null
+++ b/dev-ada/libgpr/libgpr-2017.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs multiprocessing
+
+MYP=gprbuild-gpl-${PV}
+
+DESCRIPTION="Multi-Language Management"
+HOMEPAGE="http://libre.adacore.com/"
+SRC_URI="
+ http://mirrors.cdn.adacore.com/art/591c45e2c7a447af2deecff7
+ -> ${MYP}-src.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="gnat_2016 +gnat_2017 +shared static static-pic"
+
+RDEPEND="dev-ada/xmlada[static,gnat_2016=,gnat_2017=]
+ gnat_2016? ( dev-lang/gnat-gpl:4.9.4 )
+ gnat_2017? ( dev-lang/gnat-gpl:6.3.0 )"
+DEPEND="${RDEPEND}
+ dev-ada/gprbuild"
+
+S="${WORKDIR}"/${MYP}-src
+
+REQUIRED_USE="|| ( shared static static-pic )
+ ^^ ( gnat_2016 gnat_2017 )"
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+
+src_configure() {
+ emake prefix="${D}"usr setup
+}
+
+src_compile() {
+ if use gnat_2016; then
+ GCC_PV=4.9.4
+ else
+ GCC_PV=6.3.0
+ fi
+ GCC=${CHOST}-gcc-${GCC_PV}
+ if use shared; then
+ gprbuild -p -m -j$(makeopts_jobs) -XBUILD=production -v \
+ -XLIBRARY_TYPE=relocatable -XXMLADA_BUILD=relocatable \
+ gpr/gpr.gpr -cargs:C ${CFLAGS} -cargs:Ada ${ADAFLAGS} || die
+ fi
+ for kind in static static-pic; do
+ if use ${kind}; then
+ gprbuild -p -m -j$(makeopts_jobs) -XBUILD=production -v \
+ -XLIBRARY_TYPE=${kind} -XXMLADA_BUILD=${kind} gpr/gpr.gpr \
+ -cargs:C ${CFLAGS} -cargs:Ada ${ADAFLAGS} || die
+ fi
+ done
+}
+
+src_install() {
+ for kind in shared static static-pic; do
+ if use ${kind}; then
+ emake DESTDIR="${D}" libgpr.install.${kind}
+ fi
+ done
+}