summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2020-06-10 22:51:00 +0200
committerAlfredo Tupone <tupone@gentoo.org>2020-06-10 22:51:32 +0200
commit0f984e407e1b200ce4e5cfce125fbcae9a06f5d4 (patch)
tree6827a406226a0e353ac9de4e06ddedcc69d03037 /dev-ada
parentdev-python/aws-sam-translator: Add python@ as co-maint (diff)
downloadgentoo-0f984e407e1b200ce4e5cfce125fbcae9a06f5d4.tar.gz
gentoo-0f984e407e1b200ce4e5cfce125fbcae9a06f5d4.tar.bz2
gentoo-0f984e407e1b200ce4e5cfce125fbcae9a06f5d4.zip
dev-ada/xmlada: version bump to 2020
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ada')
-rw-r--r--dev-ada/xmlada/Manifest1
-rw-r--r--dev-ada/xmlada/xmlada-2020.ebuild93
2 files changed, 94 insertions, 0 deletions
diff --git a/dev-ada/xmlada/Manifest b/dev-ada/xmlada/Manifest
index d6dbc1705d15..f92ebd81209d 100644
--- a/dev-ada/xmlada/Manifest
+++ b/dev-ada/xmlada/Manifest
@@ -1 +1,2 @@
DIST xmlada-2019-20190429-19B9D-src.tar.gz 1582603 BLAKE2B e2be3e7c0c8b843bfc808a3dd726235a82588caed8c919975a97ce34c72d6d634361bbc34208590210936add9e2f881b59d01168ef79abed1e489c50b27094d8 SHA512 f8e0e25b0aee9a7a18223ae7761603082af55134f062c767d0cd0dbf0dbcb2058fc7c57532b567fb2c6efa464a53ead57b300578e98962025866e5c3ad73e380
+DIST xmlada-2020-20200429-19A99-src.tar.gz 1533111 BLAKE2B e2c25e103c5c560cf7c9580118580e2952f3ef56c244b0f76c7f484e5629b684d5ee546d2d40520e1a4bf963271d360522423f4e7d81570f7dc1dbc8424c9147 SHA512 e53dd1fba504d2aa91ce29ea381c62adea12c5d8c72cd87396b903143279456cc6547c18035f6e988e95bd93607360075789532378f33cbe23bef9b49c8d984c
diff --git a/dev-ada/xmlada/xmlada-2020.ebuild b/dev-ada/xmlada/xmlada-2020.ebuild
new file mode 100644
index 000000000000..cbc536004e3a
--- /dev/null
+++ b/dev-ada/xmlada/xmlada-2020.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ADA_COMPAT=( gnat_201{6,7,8,9} )
+inherit ada multiprocessing
+
+MYP=${P}-20200429-19A99-src
+
+DESCRIPTION="Set of modules that provide a simple manipulation of XML streams"
+HOMEPAGE="http://libre.adacore.com/"
+SRC_URI="https://community.download.adacore.com/v1/c799502295baf074ad17b48c50f621879c392c57?filename=${MYP}.tar.gz
+ -> ${MYP}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+shared static-libs static-pic"
+REQUIRED_USE="|| ( shared static-libs static-pic )
+ ${ADA_REQUIRED_USE}"
+
+RDEPEND="${ADA_DEPS}"
+DEPEND="${RDEPEND}
+ dev-ada/gprbuild[${ADA_USEDEP}]"
+
+S="${WORKDIR}"/${MYP}
+
+PATCHES=( "${FILESDIR}"/${PN}-2019-gentoo.patch )
+
+QA_FLAGS_IGNORED=(
+ /usr/lib/xmlada/xmlada_dom.relocatable/libxmlada_dom.so.2020
+ /usr/lib/xmlada/xmlada_input.relocatable/libxmlada_input_sources.so.2020
+ /usr/lib/xmlada/xmlada_sax.relocatable/libxmlada_sax.so.2020
+ /usr/lib/xmlada/xmlada_schema.relocatable/libxmlada_schema.so.2020
+ /usr/lib/xmlada/xmlada_unicode.relocatable/libxmlada_unicode.so.2020
+)
+
+src_configure() {
+ econf --prefix="${D}"/usr
+}
+
+src_compile() {
+ build () {
+ echo gprbuild -j$(makeopts_jobs) -m -p -v -XLIBRARY_TYPE=$1 \
+ -XBUILD=Production -XPROCESSORS=$(makeopts_jobs) xmlada.gpr \
+ -largs ${LDFLAGS} \
+ -cargs ${ADAFLAGS}
+ gprbuild -j$(makeopts_jobs) -m -p -v -XLIBRARY_TYPE=$1 \
+ -XBUILD=Production -XPROCESSORS=$(makeopts_jobs) xmlada.gpr \
+ -largs ${LDFLAGS} \
+ -cargs ${ADAFLAGS} || die "gprbuild failed"
+ }
+ if use shared; then
+ build relocatable
+ fi
+ if use static-libs; then
+ build static
+ fi
+ if use static-pic; then
+ build static-pic
+ fi
+}
+
+src_test() {
+ emake test
+ emake run_test | tee xmlada.testLog
+ grep -q DIFF xmlada.testLog && die
+}
+
+src_install() {
+ build () {
+ gprinstall -XLIBRARY_TYPE=$1 -f -p -XBUILD=Production \
+ -XPROCESSORS=$(makeopts_jobs) --prefix="${D}"/usr \
+ --install-name=xmlada --build-var=LIBRARY_TYPE \
+ --build-var=XMLADA_BUILD \
+ --build-name=$1 xmlada.gpr || die "gprinstall failed"
+ }
+ if use shared; then
+ build relocatable
+ fi
+ if use static-libs; then
+ build static
+ fi
+ if use static-pic; then
+ build static-pic
+ fi
+
+ einstalldocs
+ dodoc xmlada-roadmap.txt
+ rm -f "${D}"/usr/share/doc/${PN}/.buildinfo
+ rm -rf "${D}"/usr/share/gpr/manifests
+}