summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-27 02:16:21 -0400
committerSam James <sam@gentoo.org>2024-03-29 02:28:22 +0000
commit411f7e106012a6af37a5d14e2a62572c2f0b4f6a (patch)
tree0c170b1efbc38bda7adeabb3de63f04f79e16947 /dev-build/libtool/libtool-2.4.7-r4.ebuild
parentdev-debug/strace: add 6.8 (diff)
downloadgentoo-411f7e106012a6af37a5d14e2a62572c2f0b4f6a.tar.gz
gentoo-411f7e106012a6af37a5d14e2a62572c2f0b4f6a.tar.bz2
gentoo-411f7e106012a6af37a5d14e2a62572c2f0b4f6a.zip
dev-build/libtool: simplify defining tool names to their basename
Recently a bunch more got added following the original sed style. The whole thing is incredibly wasteful and difficult to read, however. - type -P xxx will always return ${path}/xxx or nothing, which includes failing to fork in low-memory conditions, catastrophically failing the build, but NOT running "die" - basename ${path}/xxx will always return "xxx" We can simply write xxx directly. This is a confusing 2016 hack that doesn't need to be continued. Bug: https://bugs.gentoo.org/574550 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-build/libtool/libtool-2.4.7-r4.ebuild')
-rw-r--r--dev-build/libtool/libtool-2.4.7-r4.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/dev-build/libtool/libtool-2.4.7-r4.ebuild b/dev-build/libtool/libtool-2.4.7-r4.ebuild
index d165475452d8..73de49e5d15f 100644
--- a/dev-build/libtool/libtool-2.4.7-r4.ebuild
+++ b/dev-build/libtool/libtool-2.4.7-r4.ebuild
@@ -101,12 +101,12 @@ src_configure() {
# Do not bother hardcoding the full path to sed.
# Just rely on $PATH. bug #574550
export CONFIG_SHELL="${EPREFIX}"/bin/bash
- export ac_cv_path_SED="$(basename "$(type -P sed)")"
- export ac_cv_path_EGREP="$(basename "$(type -P grep)") -E"
- export ac_cv_path_EGREP_TRADITIONAL="$(basename "$(type -P grep)") -E"
- export ac_cv_path_FGREP="$(basename "$(type -P grep)") -F"
- export ac_cv_path_GREP="$(basename "$(type -P grep)")"
- export ac_cv_path_lt_DD="$(basename "$(type -P dd)")"
+ export ac_cv_path_SED="sed"
+ export ac_cv_path_EGREP="grep -E"
+ export ac_cv_path_EGREP_TRADITIONAL="grep -E"
+ export ac_cv_path_FGREP="grep -F"
+ export ac_cv_path_GREP="grep"
+ export ac_cv_path_lt_DD="dd"
[[ ${CHOST} == *-darwin* ]] && local myconf="--program-prefix=g"