summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2024-03-15 06:51:37 -0700
committerSam James <sam@gentoo.org>2024-03-15 19:29:22 +0000
commit341f85a7caa16a7d986a4b428521562bf9120b08 (patch)
tree96179f3abeecd48a1b4805506921c190b838c906 /dev-build
parentsec-keys/openpgp-keys-midipix: add 20240315, drop 20231115 (diff)
downloadgentoo-341f85a7caa16a7d986a4b428521562bf9120b08.tar.gz
gentoo-341f85a7caa16a7d986a4b428521562bf9120b08.tar.bz2
gentoo-341f85a7caa16a7d986a4b428521562bf9120b08.zip
dev-build/slibtool: add 0.5.36
Many bugs are fixed with this release, it is recommended for slibtool users to rebuild their entire system after this release. The addition of -export-symbols and -export-symbols-regex will allow exporting only the desired public symbols globally in any package that uses them. Closes: https://bugs.gentoo.org/925555 Closes: https://bugs.gentoo.org/913670 Closes: https://bugs.gentoo.org/916128 Closes: https://bugs.gentoo.org/775596 Closes: https://bugs.gentoo.org/792072 Closes: https://bugs.gentoo.org/924407 Closes: https://bugs.gentoo.org/924291 Closes: https://bugs.gentoo.org/782013 Closes: https://bugs.gentoo.org/914569 Closes: https://bugs.gentoo.org/791880 Closes: https://bugs.gentoo.org/913551 Closes: https://bugs.gentoo.org/913688 Closes: https://bugs.gentoo.org/914097 Closes: https://bugs.gentoo.org/915966 Closes: https://bugs.gentoo.org/924408 Closes: https://bugs.gentoo.org/915121 Closes: https://bugs.gentoo.org/913642 Closes: https://bugs.gentoo.org/917639 Closes: https://bugs.gentoo.org/917640 Closes: https://bugs.gentoo.org/913530 Closes: https://bugs.gentoo.org/913638 Closes: https://bugs.gentoo.org/778515 Closes: https://bugs.gentoo.org/920190 Closes: https://bugs.gentoo.org/924404 Signed-off-by: orbea <orbea@riseup.net> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-build')
-rw-r--r--dev-build/slibtool/Manifest2
-rw-r--r--dev-build/slibtool/slibtool-0.5.36.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-build/slibtool/Manifest b/dev-build/slibtool/Manifest
index af20d6cfbe99..1e5e05d1338c 100644
--- a/dev-build/slibtool/Manifest
+++ b/dev-build/slibtool/Manifest
@@ -1,2 +1,4 @@
DIST slibtool-0.5.35.tar.xz 87964 BLAKE2B cd01e3dc479cde2ffd8b58c51273b6c6f503056f009aa960b79dd0a6d2d18c73a3dfd9eb7933f24fd47ff849911cb63ca014eadd2bf661e3c0236467eb0802ff SHA512 e1d2f03596432f970f8c1f93d4387cafb11355a520fb5adb9bbc02f3dcdea0bbb78ca6fe84c24faebee848279050c5bec13fd64a168b12d7fc885ac9d31a7560
DIST slibtool-0.5.35.tar.xz.sig 833 BLAKE2B 597d5beb51f650643f1ef1c8f576200ccda154e9428e5097c2236e8d71992a4c9c39d44c1325f9f1265e1cfa49f08581546c0b0f8019c7796ce9271219480753 SHA512 2a7333997802ef56a57bf32fbfce17030c1dd732c9066bec94d0719cbda3dc85e896a0221e43065fc3ed35ee852942a5f7c270d56276706b9f0fdb7f4d091ef8
+DIST slibtool-0.5.36.tar.xz 119504 BLAKE2B 62c58b291573094d480176c2cbb38e161fe4f9ec5beb27d519eea6ca92191dc4bd5088226e2905393318108631cfcbfd1522af9372da0466932211439cf2081a SHA512 afdbef68f25c2079fb1e900052bb8d8cb3b5db67ca2a43ec144d0b6de76ff3452b09ce380acf58ce3d5a71c597ce6d5a9dbfacb5cb6134a71f7f863760e43cdb
+DIST slibtool-0.5.36.tar.xz.sig 833 BLAKE2B 0eb52ee00098e7e9e0c31520b0b5fb5d8441fb3aee372b01caa78c6667ee476d6f18d64bfc15980509826ceb275b5a8411ae140f75149c8e13d33d4a89212984 SHA512 6858230c0aa599021ff1cce622f7fd6abba82c5343a798915d4a43a9fa21119f70d38935aed00617930468adc82f7d3291c8c3da42a06f8153102fb188427bc6
diff --git a/dev-build/slibtool/slibtool-0.5.36.ebuild b/dev-build/slibtool/slibtool-0.5.36.ebuild
new file mode 100644
index 000000000000..c45f9f0cddeb
--- /dev/null
+++ b/dev-build/slibtool/slibtool-0.5.36.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+# git.foss21.org is the official repository per upstream
+DESCRIPTION="A strong libtool implementation, written in C"
+HOMEPAGE="https://git.foss21.org/slibtool"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.foss21.org/slibtool"
+else
+ VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/midipix.asc
+ inherit verify-sig
+
+ SRC_URI="https://dl.midipix.org/slibtool/${P}.tar.xz"
+ SRC_URI+=" verify-sig? ( https://dl.midipix.org/slibtool/${P}.tar.xz.sig )"
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+fi
+
+BDEPEND="sys-devel/m4"
+
+if [[ ${PV} != *9999 ]] ; then
+ BDEPEND+=" verify-sig? ( sec-keys/openpgp-keys-midipix )"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+src_configure() {
+ # Custom configure script (not generated by autoconf)
+ ./configure \
+ --compiler="$(tc-getCC)" \
+ --host=${CHOST} \
+ --prefix="${EPREFIX}"/usr \
+ --libdir="${EPREFIX}/usr/$(get_libdir)" \
+ || die
+}