summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-03-04 18:08:49 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-03-04 22:56:44 +0100
commit6e4fb2b43339fa5df77a346fb71235b30844ab58 (patch)
tree58e23c5e0d96c913c7e14891d52289358de73314 /dev-build
parentgames-engines/openmw: fix build with gcc 14 (diff)
downloadgentoo-6e4fb2b43339fa5df77a346fb71235b30844ab58.tar.gz
gentoo-6e4fb2b43339fa5df77a346fb71235b30844ab58.tar.bz2
gentoo-6e4fb2b43339fa5df77a346fb71235b30844ab58.zip
dev-build/bazelisk: support bazel-symlink
Closes: https://bugs.gentoo.org/926104 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-build')
-rw-r--r--dev-build/bazelisk/bazelisk-1.19.0-r1.ebuild (renamed from dev-build/bazelisk/bazelisk-1.19.0.ebuild)5
-rw-r--r--dev-build/bazelisk/metadata.xml7
2 files changed, 10 insertions, 2 deletions
diff --git a/dev-build/bazelisk/bazelisk-1.19.0.ebuild b/dev-build/bazelisk/bazelisk-1.19.0-r1.ebuild
index 4cea472f3598..9b18306d7e1b 100644
--- a/dev-build/bazelisk/bazelisk-1.19.0.ebuild
+++ b/dev-build/bazelisk/bazelisk-1.19.0-r1.ebuild
@@ -16,6 +16,7 @@ SRC_URI="
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="+bazel-symlink"
DOCS=( CONTRIBUTING.md README.md )
@@ -34,5 +35,9 @@ src_install() {
exeinto /usr/bin
doexe "bin/${PN}"
+ if use bazel-symlink ; then
+ dosym -r /usr/bin/bazelisk /usr/bin/bazel
+ fi
+
einstalldocs
}
diff --git a/dev-build/bazelisk/metadata.xml b/dev-build/bazelisk/metadata.xml
index 032d00abaf95..de81e5f355e3 100644
--- a/dev-build/bazelisk/metadata.xml
+++ b/dev-build/bazelisk/metadata.xml
@@ -7,12 +7,15 @@
<name>Maciej Barć</name>
</maintainer>
<longdescription>
- Bazelisk is a wrapper for Bazel written in Go. It automatically picks
- a good version of Bazel given your current working directory, downloads it
+ Bazelisk is a wrapper for Bazel written in Go. It automatically picks a
+ good version of Bazel given your current working directory, downloads it
from the official server (if required) and then transparently passes
through all command-line arguments to the real Bazel binary. You can call
it just like you would call Bazel.
</longdescription>
+ <use>
+ <flag name="bazel-symlink">Install bazel symlink that points to bazelisk</flag>
+ </use>
<upstream>
<bugs-to>https://github.com/bazelbuild/bazelisk/issues/</bugs-to>
<remote-id type="github">bazelbuild/bazelisk</remote-id>