summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2024-03-07 10:25:47 +0100
committerDavid Seifert <soap@gentoo.org>2024-03-07 10:25:47 +0100
commita7b3f502c94f6eedc7ceed360b9758571ed4c4b3 (patch)
tree22910c0788edd237677856d4b71e330e5aea5e4d /dev-build
parentmedia-libs/libva-intel-media-driver: Stabilize 24.1.3 amd64, #926303 (diff)
downloadgentoo-a7b3f502c94f6eedc7ceed360b9758571ed4c4b3.tar.gz
gentoo-a7b3f502c94f6eedc7ceed360b9758571ed4c4b3.tar.bz2
gentoo-a7b3f502c94f6eedc7ceed360b9758571ed4c4b3.zip
dev-build/b2: drop 4.10.1
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-build')
-rw-r--r--dev-build/b2/Manifest1
-rw-r--r--dev-build/b2/b2-4.10.1.ebuild70
-rw-r--r--dev-build/b2/files/b2-4.9.2-odr.patch54
3 files changed, 0 insertions, 125 deletions
diff --git a/dev-build/b2/Manifest b/dev-build/b2/Manifest
index 88a04888a951..ba055543ca84 100644
--- a/dev-build/b2/Manifest
+++ b/dev-build/b2/Manifest
@@ -1,2 +1 @@
-DIST b2-4.10.1.tar.gz 982429 BLAKE2B bb1e6ef741ca10d3b0029e64d69a7ee7eb0d40d26c68d2a3932d4210e8e2a83131c9bac2d54f2885373725d58fe73dd7fa7aebfc5781059f01c3462c738d426c SHA512 0bc4897a342685190626a6593926c4b200c5ca9b498ba77287a7c49467a8e3f65cb850b9616fd05d4aea9ebfab32ec46792d7d8226bed89911a711ce14ecce30
DIST b2-5.0.0.tar.gz 1015818 BLAKE2B 87b6f34733002479f91f658aee4f776930ae6441f33b2540b82049e18c4199280e73047afafa90dc156cc75db8b587c5bb9e2ce65d93c493775ac4107ce3201b SHA512 37403f0bd863753c5313393405dd8514a4f8d9f0839ccd397ee1856e02af6116bd238d345e5b766512441ca1c0b09883386588e270bd982eca45235eef1b01b7
diff --git a/dev-build/b2/b2-4.10.1.ebuild b/dev-build/b2/b2-4.10.1.ebuild
deleted file mode 100644
index 55ca9c3a4e4c..000000000000
--- a/dev-build/b2/b2-4.10.1.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit edo flag-o-matic toolchain-funcs
-
-MY_PV="$(ver_rs 1- _)"
-
-DESCRIPTION="A system for large project software construction, simple to use and powerful"
-HOMEPAGE="https://www.bfgroup.xyz/b2/"
-SRC_URI="https://github.com/bfgroup/b2/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${P}/src"
-
-LICENSE="Boost-1.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="examples"
-RESTRICT="test"
-
-RDEPEND="!dev-util/boost-build"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-4.9.2-disable_python_rpath.patch
- "${FILESDIR}"/${PN}-4.9.2-darwin-gentoo-toolchain.patch
- "${FILESDIR}"/${PN}-4.9.2-add-none-feature-options.patch
- "${FILESDIR}"/${PN}-4.9.2-no-implicit-march-flags.patch
- "${FILESDIR}"/${PN}-4.9.2-odr.patch
-)
-
-src_configure() {
- # need to enable LFS explicitly for 64-bit offsets on 32-bit hosts (#761100)
- append-lfs-flags
-}
-
-src_compile() {
- cd engine || die
-
- # upstream doesn't want separate flags for CPPFLAGS/LDFLAGS
- # https://github.com/bfgroup/b2/pull/187#issuecomment-1335688424
- edo ${CONFIG_SHELL:-${BASH}} ./build.sh cxx \
- --cxx="$(tc-getCXX)" \
- --cxxflags="${CXXFLAGS} ${CPPFLAGS} ${LDFLAGS}" \
- -d+2 \
- --without-python
-}
-
-src_test() {
- # Forget tests, b2 is a lost cause
- :
-}
-
-src_install() {
- dobin engine/b2
-
- insinto /usr/share/b2/src
- doins -r "${FILESDIR}/site-config.jam" \
- bootstrap.jam build-system.jam ../example/user-config.jam \
- build kernel options tools util
-
- find "${ED}"/usr/share/b2/src -iname '*.py' -delete || die
-
- dodoc ../notes/{changes,release_procedure,build_dir_option,relative_source_paths}.txt
-
- if use examples; then
- docinto examples
- dodoc -r ../example/.
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}
diff --git a/dev-build/b2/files/b2-4.9.2-odr.patch b/dev-build/b2/files/b2-4.9.2-odr.patch
deleted file mode 100644
index 62cbca189640..000000000000
--- a/dev-build/b2/files/b2-4.9.2-odr.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-Avoid ODR violations by giving "_stack" internal linkage
-https://bugs.gentoo.org/858320
-
---- a/engine/function.cpp
-+++ b/engine/function.cpp
-@@ -213,11 +213,11 @@
- } JAM_FUNCTION;
-
-
-+namespace
-+{
- typedef struct _stack STACK;
- typedef STACK* stack_ptr;
-
--namespace
--{
- template <typename T>
- using remove_cref_t
- = typename std::remove_const<
-@@ -260,7 +260,6 @@
- typename select_last_impl<(sizeof...(A) == 1), type_list<A...> >
- ::template type<A...>;
- #endif
--}
-
- struct _stack
- {
-@@ -439,6 +438,8 @@
- cleanups_size += n;
- }
-
-+}
-+
- static STACK * stack_global()
- {
- static _stack singleton;
---- a/engine/make1.cpp
-+++ b/engine/make1.cpp
-@@ -86,6 +86,7 @@
- #define T_STATE_MAKE1B 1 /* make1b() should be called */
- #define T_STATE_MAKE1C 2 /* make1c() should be called */
-
-+namespace {
- typedef struct _state state;
- struct _state
- {
-@@ -94,6 +95,7 @@
- TARGET * parent; /* parent argument necessary for MAKE1A */
- int32_t curstate; /* current state */
- };
-+}
-
- static void make1a( state * const );
- static void make1b( state * const );