summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorwangjiezhe <wangjiezhe@gmail.com>2024-01-20 11:18:22 +0800
committerJason Zaman <perfinion@gentoo.org>2024-02-03 11:32:52 -0800
commite9b99e43843a56b446dacfb90c9881e743ac7249 (patch)
treeedddfa14c9af4403a2e1eb888736ceb2dd17130a /dev-build
parentsci-libs/tensorflow-estimator: add 2.13.0 (diff)
downloadgentoo-e9b99e43843a56b446dacfb90c9881e743ac7249.tar.gz
gentoo-e9b99e43843a56b446dacfb90c9881e743ac7249.tar.bz2
gentoo-e9b99e43843a56b446dacfb90c9881e743ac7249.zip
dev-build/bazel: add notation for gcc-13 compilation issue
Bug: https://bugs.gentoo.org/906914 Bug: https://bugs.gentoo.org/917689 Bug: https://bugs.gentoo.org/918703 Signed-off-by: wangjiezhe <wangjiezhe@gmail.com> Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'dev-build')
-rw-r--r--dev-build/bazel/bazel-5.3.0.ebuild8
-rw-r--r--dev-build/bazel/bazel-6.2.0.ebuild8
2 files changed, 14 insertions, 2 deletions
diff --git a/dev-build/bazel/bazel-5.3.0.ebuild b/dev-build/bazel/bazel-5.3.0.ebuild
index 1afd007db9d4..f756db0dbc6a 100644
--- a/dev-build/bazel/bazel-5.3.0.ebuild
+++ b/dev-build/bazel/bazel-5.3.0.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit bash-completion-r1 bazel java-pkg-2 multiprocessing
+inherit bash-completion-r1 bazel java-pkg-2 multiprocessing toolchain-funcs
DESCRIPTION="Fast and correct automated build system"
HOMEPAGE="https://bazel.build/"
@@ -30,6 +30,12 @@ pkg_setup() {
ewarn "${PN} usually fails to compile with ccache, you have been warned"
fi
java-pkg-2_pkg_setup
+
+ if [[ ${MERGE_TYPE} != binary ]] && tc-is-gcc && ver_test $(gcc-version) -ge 13 ; then
+ eerror "Bazel 6 needs <=gcc-12 to compile."
+ eerror "Please run 'eselect gcc' and set correct gcc version."
+ die "GCC version is too new to compile Bazel!"
+ fi
}
src_unpack() {
diff --git a/dev-build/bazel/bazel-6.2.0.ebuild b/dev-build/bazel/bazel-6.2.0.ebuild
index 1afd007db9d4..f756db0dbc6a 100644
--- a/dev-build/bazel/bazel-6.2.0.ebuild
+++ b/dev-build/bazel/bazel-6.2.0.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit bash-completion-r1 bazel java-pkg-2 multiprocessing
+inherit bash-completion-r1 bazel java-pkg-2 multiprocessing toolchain-funcs
DESCRIPTION="Fast and correct automated build system"
HOMEPAGE="https://bazel.build/"
@@ -30,6 +30,12 @@ pkg_setup() {
ewarn "${PN} usually fails to compile with ccache, you have been warned"
fi
java-pkg-2_pkg_setup
+
+ if [[ ${MERGE_TYPE} != binary ]] && tc-is-gcc && ver_test $(gcc-version) -ge 13 ; then
+ eerror "Bazel 6 needs <=gcc-12 to compile."
+ eerror "Please run 'eselect gcc' and set correct gcc version."
+ die "GCC version is too new to compile Bazel!"
+ fi
}
src_unpack() {