summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-01-02 23:01:33 +0100
committerDavid Seifert <soap@gentoo.org>2023-01-02 23:01:33 +0100
commit676a9635b3be275ba6ce4c28b60f37d1ad5a8bf4 (patch)
tree337da678e42c27087bc4711b4fe70635bbe97d74 /dev-cpp/antlr-cpp/antlr-cpp-4.11.1.ebuild
parentapp-crypt/seahorse: fix build w/ gnupg 2.4 (diff)
downloadgentoo-676a9635b3be275ba6ce4c28b60f37d1ad5a8bf4.tar.gz
gentoo-676a9635b3be275ba6ce4c28b60f37d1ad5a8bf4.tar.bz2
gentoo-676a9635b3be275ba6ce4c28b60f37d1ad5a8bf4.zip
dev-cpp/antlr-cpp: add 4.11.1
Bug: https://bugs.gentoo.org/726866 Bug: https://bugs.gentoo.org/881317 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-cpp/antlr-cpp/antlr-cpp-4.11.1.ebuild')
-rw-r--r--dev-cpp/antlr-cpp/antlr-cpp-4.11.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-cpp/antlr-cpp/antlr-cpp-4.11.1.ebuild b/dev-cpp/antlr-cpp/antlr-cpp-4.11.1.ebuild
new file mode 100644
index 000000000000..f184f2fc1c2c
--- /dev/null
+++ b/dev-cpp/antlr-cpp/antlr-cpp-4.11.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="The ANTLR 4 C++ Runtime"
+HOMEPAGE="https://www.antlr.org/"
+SRC_URI="https://www.antlr.org/download/antlr4-cpp-runtime-${PV}-source.zip -> ${P}.zip"
+S="${WORKDIR}"
+
+LICENSE="BSD"
+SLOT="4"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-cpp/gtest )"
+BDEPEND="app-arch/unzip"
+
+PATCHES=( "${FILESDIR}"/${PV}-GNUInstallDirs.patch )
+
+src_configure() {
+ local mycmakeargs=(
+ -DANTLR_BUILD_CPP_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}