summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Strogin <stefan.strogin@gmail.com>2019-04-18 00:22:11 +0300
committerMichał Górny <mgorny@gentoo.org>2019-04-22 12:21:29 +0200
commita7e7f55e5847573e2a72779ef58f23e0f383d5c3 (patch)
tree3859a297d10259a27b38bcf7d9a66355de977854 /dev-cpp/asio/asio-1.12.2.ebuild
parentnet-vpn/i2p: drop 0.9.3[67] (diff)
downloadgentoo-a7e7f55e5847573e2a72779ef58f23e0f383d5c3.tar.gz
gentoo-a7e7f55e5847573e2a72779ef58f23e0f383d5c3.tar.bz2
gentoo-a7e7f55e5847573e2a72779ef58f23e0f383d5c3.zip
dev-cpp/asio: bump version to 1.12.2
Update HOMEPAGE; EAPI=7. Package-Manager: Portage-2.3.63, Repoman-2.3.12 Signed-off-by: Stefan Strogin <stefan.strogin@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-cpp/asio/asio-1.12.2.ebuild')
-rw-r--r--dev-cpp/asio/asio-1.12.2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-cpp/asio/asio-1.12.2.ebuild b/dev-cpp/asio/asio-1.12.2.ebuild
new file mode 100644
index 000000000000..fe556e8cbee7
--- /dev/null
+++ b/dev-cpp/asio/asio-1.12.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Asynchronous Network Library"
+HOMEPAGE="https://think-async.com"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/${P}.tar.bz2"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc examples libressl ssl test"
+
+RDEPEND="dev-libs/boost
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ if ! use test; then
+ # Don't build nor install any examples or unittests
+ # since we don't have a script to run them
+ cat > src/Makefile.in <<-EOF || die
+ all:
+
+ install:
+
+ clean:
+ EOF
+ fi
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( doc/. )
+ default
+
+ if use examples; then
+ # Get rid of the object files
+ emake clean
+ dodoc -r src/examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}