summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <sokolov@google.com>2020-07-10 11:10:33 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-07-24 15:03:32 +0300
commitd1595c288ebbb12ca7ea7223481900ddfafc720c (patch)
tree93ed154d30a20aa27d73c8a5bcfd8e3f3fa62aec /dev-cpp/asio/asio-1.17.0.ebuild
parentdev-libs/json-c: Change USE to cpu_flags_x86_rdrand (diff)
downloadgentoo-d1595c288ebbb12ca7ea7223481900ddfafc720c.tar.gz
gentoo-d1595c288ebbb12ca7ea7223481900ddfafc720c.tar.bz2
gentoo-d1595c288ebbb12ca7ea7223481900ddfafc720c.zip
dev-cpp/asio: version 1.17.0
Package-Manager: Portage-2.3.99, Repoman-2.3.23 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Closes: https://github.com/gentoo/gentoo/pull/16656 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-cpp/asio/asio-1.17.0.ebuild')
-rw-r--r--dev-cpp/asio/asio-1.17.0.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-cpp/asio/asio-1.17.0.ebuild b/dev-cpp/asio/asio-1.17.0.ebuild
new file mode 100644
index 000000000000..1a7e5378adbc
--- /dev/null
+++ b/dev-cpp/asio/asio-1.17.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Asynchronous Network Library"
+HOMEPAGE="https://think-async.com https://github.com/chriskohlhoff/asio"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/${P}.tar.bz2"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc examples libressl ssl test"
+RESTRICT="!test? ( test )"
+# test searches for libssl during ./configure, and REQUIRED_USE is easier than
+# patching configure to not search for it with USE=-ssl
+REQUIRED_USE="test? ( ssl )"
+
+RDEPEND="dev-libs/boost
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ if ! use test; then
+ # Don't build nor install any examples or unittests
+ # since we don't have a script to run them
+ cat > src/Makefile.in <<-EOF || die
+ all:
+
+ install:
+
+ clean:
+ EOF
+ fi
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( doc/. )
+ default
+
+ if use examples; then
+ # Get rid of the object files
+ emake clean
+ dodoc -r src/examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}