summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatoro Mahri <matoro_gentoo@matoro.tk>2024-03-12 15:42:19 -0400
committerSam James <sam@gentoo.org>2024-03-21 02:27:07 +0000
commit49b492cfbba12d2fa7c681e384ea967f5a800937 (patch)
treeeb59c1e36317102a524047e763d8f89693f10940 /dev-cpp/benchmark/benchmark-1.8.3-r1.ebuild
parentmedia-libs/libpulse: add patch removing catch2 internal test timeouts (diff)
downloadgentoo-49b492cfbba12d2fa7c681e384ea967f5a800937.tar.gz
gentoo-49b492cfbba12d2fa7c681e384ea967f5a800937.tar.bz2
gentoo-49b492cfbba12d2fa7c681e384ea967f5a800937.zip
dev-cpp/benchmark: add patches for alpha architecture
Accepted upstream already. See: https://github.com/google/benchmark/pull/1753 See: https://github.com/google/benchmark/pull/1756 Bug: https://bugs.gentoo.org/922877 Signed-off-by: Matoro Mahri <matoro_gentoo@matoro.tk> Closes: https://github.com/gentoo/gentoo/pull/35729 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-cpp/benchmark/benchmark-1.8.3-r1.ebuild')
-rw-r--r--dev-cpp/benchmark/benchmark-1.8.3-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-cpp/benchmark/benchmark-1.8.3-r1.ebuild b/dev-cpp/benchmark/benchmark-1.8.3-r1.ebuild
new file mode 100644
index 000000000000..5c20bb79f760
--- /dev/null
+++ b/dev-cpp/benchmark/benchmark-1.8.3-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="A microbenchmark support library"
+HOMEPAGE="https://github.com/google/benchmark"
+SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="debug doc test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="doc? ( app-text/doxygen )
+ test? ( >=dev-cpp/gtest-1.11.0 )"
+PATCHES=(
+ "${FILESDIR}/${PN}-1.8.3-fix-32bit-test.patch"
+ "${FILESDIR}/${PN}-1.8.3-backport-pr1753.patch"
+ "${FILESDIR}/${PN}-1.8.3-backport-pr1756.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBENCHMARK_ENABLE_ASSEMBLY_TESTS=OFF
+ -DBENCHMARK_ENABLE_DOXYGEN=$(usex doc)
+ -DBENCHMARK_ENABLE_GTEST_TESTS=$(usex test)
+ -DBENCHMARK_ENABLE_TESTING=$(usex test)
+ -DBENCHMARK_ENABLE_WERROR=OFF
+ -DBENCHMARK_USE_BUNDLED_GTEST=OFF
+ )
+
+ use debug || append-cppflags -DNDEBUG
+
+ cmake_src_configure
+}