summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-06-28 07:37:16 +0200
committerMichał Górny <mgorny@gentoo.org>2017-06-28 10:23:05 +0200
commit8fdde6fa6c3af61d676733967ea02de60a16263c (patch)
tree84a89936b8237d34901bd315b11fdfd221535372 /dev-cpp/catch/catch-1.9.6.ebuild
parentapp-shells/bash-completion: Bump to 2.6 (diff)
downloadgentoo-8fdde6fa6c3af61d676733967ea02de60a16263c.tar.gz
gentoo-8fdde6fa6c3af61d676733967ea02de60a16263c.tar.bz2
gentoo-8fdde6fa6c3af61d676733967ea02de60a16263c.zip
dev-cpp/catch: Bump to 1.9.6
Diffstat (limited to 'dev-cpp/catch/catch-1.9.6.ebuild')
-rw-r--r--dev-cpp/catch/catch-1.9.6.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-cpp/catch/catch-1.9.6.ebuild b/dev-cpp/catch/catch-1.9.6.ebuild
new file mode 100644
index 000000000000..dd8e74f2615d
--- /dev/null
+++ b/dev-cpp/catch/catch-1.9.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Modern C++ header-only framework for unit-tests"
+HOMEPAGE="https://github.com/philsquared/Catch"
+SRC_URI="https://github.com/philsquared/Catch/archive/v${PV}.tar.gz -> ${P^}.tar.gz"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S=${WORKDIR}/${P^}
+
+# CMake is only used to build & run tests, so override phases
+src_configure() { :; }
+src_compile() { :; }
+
+src_test() {
+ cmake-utils_src_configure
+ cmake-utils_src_compile
+ cmake-utils_src_test
+}
+
+src_install() {
+ # same location as used in fedora
+ insinto /usr/include/catch
+ doins -r include/.
+ dodoc -r docs/.
+}