summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-05-24 12:35:02 +0200
committerMichał Górny <mgorny@gentoo.org>2016-05-24 13:23:08 +0200
commit050962ba13269e126d131c75d045aa1dc9449981 (patch)
tree8fb7ca4f40f24e069fa4a761eb0a930aa89ff719 /dev-cpp/catch/catch-9999.ebuild
parentdev-lang/ucblogo: Bump to version 6.0 (diff)
downloadgentoo-050962ba13269e126d131c75d045aa1dc9449981.tar.gz
gentoo-050962ba13269e126d131c75d045aa1dc9449981.tar.bz2
gentoo-050962ba13269e126d131c75d045aa1dc9449981.zip
dev-cpp/catch: New package, used by tests in dev-cpp/libjson-rpc-cpp
Diffstat (limited to 'dev-cpp/catch/catch-9999.ebuild')
-rw-r--r--dev-cpp/catch/catch-9999.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-cpp/catch/catch-9999.ebuild b/dev-cpp/catch/catch-9999.ebuild
new file mode 100644
index 000000000000..ee8fefd8da7c
--- /dev/null
+++ b/dev-cpp/catch/catch-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+EGIT_REPO_URI="https://github.com/philsquared/Catch.git"
+inherit cmake-utils git-r3
+
+DESCRIPTION="Modern C++ header-only framework for unit-tests"
+HOMEPAGE="https://github.com/philsquared/Catch"
+SRC_URI=""
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+
+CMAKE_USE_DIR=${S}/projects/CMake
+
+src_configure() {
+ # CMake is only used to build & run tests
+ use test && cmake-utils_src_configure
+}
+
+src_compile() {
+ use test && cmake-utils_src_compile
+}
+
+src_test() {
+ use test && cmake-utils_src_test
+}
+
+src_install() {
+ # same location as used in fedora
+ insinto /usr/include/catch
+ doins -r include/.
+ dodoc -r docs/.
+}