summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-04-26 19:00:02 +0200
committerDavid Seifert <soap@gentoo.org>2019-04-26 19:00:02 +0200
commitf749843d9b856f9686d37e6cd6cd6ee7920af3d4 (patch)
tree2d3864f0079d0cf4d0c50c8418387ba4a33ca499 /dev-cpp/catch
parentdev-lang/spidermonkey: use CONFIG_SHELL instead of SHELL (diff)
downloadgentoo-f749843d9b856f9686d37e6cd6cd6ee7920af3d4.tar.gz
gentoo-f749843d9b856f9686d37e6cd6cd6ee7920af3d4.tar.bz2
gentoo-f749843d9b856f9686d37e6cd6cd6ee7920af3d4.zip
dev-cpp/catch: Remove old
Package-Manager: Portage-2.3.64, Repoman-2.3.12 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-cpp/catch')
-rw-r--r--dev-cpp/catch/Manifest1
-rw-r--r--dev-cpp/catch/catch-2.3.0.ebuild48
-rw-r--r--dev-cpp/catch/files/catch-2.3.0-python-automagic.patch25
3 files changed, 0 insertions, 74 deletions
diff --git a/dev-cpp/catch/Manifest b/dev-cpp/catch/Manifest
index f5308e4ab98b..55da757fdf11 100644
--- a/dev-cpp/catch/Manifest
+++ b/dev-cpp/catch/Manifest
@@ -1,4 +1,3 @@
DIST Catch-1.12.2.tar.gz 377265 BLAKE2B bc27b4daee950f8fb93d65f3aed032e72bc856ee27a8dc28c35b89e33f414d68ba4cf00951e476688eddf9e4c0514036bd6916fa6cfa9e3359e6c625984f114f SHA512 ed963cdca9fe307ee02928677f81cafcb41cd607faaa315182fdf898d0f2aa28f0be2141bd642f46fdfac400c38f6d065e00a595a1e5879fe2335c4a3851e844
-DIST Catch2-2.3.0.tar.gz 506374 BLAKE2B f692eb0933ca578edf0f15cb83139d2fab03390b3980a686ea495101165d612c848b642ad1e7233bce5bb164c80958c9cbfbc229e72a1ae6947aa4dffdf27556 SHA512 e9a089b504c339e87bda0fb1a4040d9d19c932a4bc7dca41bdad6edfcf8c428f4152ff1e0c898dfdf6b20bd5d901c343bed00ad89351fa5182f3c106e0fb4b03
DIST Catch2-2.5.0.tar.gz 549328 BLAKE2B a32941a043a654228cc541dc675ad789f5b938ebc2d3177d1657f66f68fb175bec8c88a60ecba00e84eca74a7506dc83aed74ac89f7dde83213284eb4a497225 SHA512 420f1d1a5ea7b69be9fb316a8abe1fb7c7e78d44a982e883748f1e0c8d2a435c1518b6022742716019558a740f8b31977ed6a786b0293e0504206b016801cfe8
DIST Catch2-2.7.0.tar.gz 569753 BLAKE2B cec11d79c85ac8a5577467ceb4722a2441a1dbd2fbe42fb06324113d2a6f9fadc12de351735900817274520bf8533ec245ba0a3686c8c1b4813cf3136d6d552f SHA512 ab6c816642a92418c76c8ddabf17eb0c19bef1dc6ac2405c820280d670ef1d78c9ae89909f5a36bf063f0939d253b7c6b5e845c1ac4e63b338927e125dee950d
diff --git a/dev-cpp/catch/catch-2.3.0.ebuild b/dev-cpp/catch/catch-2.3.0.ebuild
deleted file mode 100644
index 33544077cdf5..000000000000
--- a/dev-cpp/catch/catch-2.3.0.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
-
-: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
-inherit cmake-utils python-any-r1
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/catchorg/Catch2.git"
-else
- MY_P=${PN^}2-${PV}
- SRC_URI="https://github.com/catchorg/Catch2/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
- KEYWORDS="amd64 x86"
-
- S=${WORKDIR}/${MY_P}
-fi
-
-DESCRIPTION="Modern C++ header-only framework for unit-tests"
-HOMEPAGE="https://github.com/catchorg/Catch2"
-
-LICENSE="Boost-1.0"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="test? ( ${PYTHON_DEPS} )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2.3.0-python-automagic.patch
-)
-
-pkg_setup() {
- use test && python-any-r1_pkg_setup
-}
-
-src_configure() {
- local mycmakeargs=(
- -DCATCH_ENABLE_WERROR=OFF
- -DBUILD_TESTING=$(usex test)
- -DCMAKE_INSTALL_DOCDIR="share/doc/${PF}"
- -DPYTHON_EXECUTABLE="${PYTHON}"
- )
- cmake-utils_src_configure
-}
diff --git a/dev-cpp/catch/files/catch-2.3.0-python-automagic.patch b/dev-cpp/catch/files/catch-2.3.0-python-automagic.patch
deleted file mode 100644
index c7fa4c6d22f6..000000000000
--- a/dev-cpp/catch/files/catch-2.3.0-python-automagic.patch
+++ /dev/null
@@ -1,25 +0,0 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -36,7 +36,11 @@
- set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} /ENTRY:wmainCRTStartup")
- endif()
-
-+find_package(PythonInterp)
- if (BUILD_TESTING AND CATCH_BUILD_TESTING AND NOT_SUBPROJECT)
-+ if (NOT PYTHONINTERP_FOUND)
-+ message(FATAL_ERROR "Python not found, but required for tests")
-+ endif()
- add_subdirectory(projects)
- endif()
-
---- a/projects/CMakeLists.txt
-+++ b/projects/CMakeLists.txt
-@@ -317,7 +317,7 @@
- set_tests_properties(NoTest PROPERTIES PASS_REGULAR_EXPRESSION "No test cases matched")
-
- # AppVeyor has a Python 2.7 in path, but doesn't have .py files as autorunnable
--add_test(NAME ApprovalTests COMMAND python ${CATCH_DIR}/scripts/approvalTests.py $<TARGET_FILE:SelfTest>)
-+add_test(NAME ApprovalTests COMMAND ${PYTHON_EXECUTABLE} ${CATCH_DIR}/scripts/approvalTests.py $<TARGET_FILE:SelfTest>)
- set_tests_properties(ApprovalTests PROPERTIES FAIL_REGULAR_EXPRESSION "Results differed")
-
- if (CATCH_USE_VALGRIND)