summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-07-12 16:43:07 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-07-12 16:43:19 -0500
commitcef788711865f86dec3a5eac3deb081217aaf608 (patch)
tree3ba9b37780af1925a5c80c9ca02ac81956365001 /dev-cpp/cpp-hocon/cpp-hocon-0.3.0.ebuild
parentsys-power/powertop: Depend on sys-devel/autoconf-archive (diff)
downloadgentoo-cef788711865f86dec3a5eac3deb081217aaf608.tar.gz
gentoo-cef788711865f86dec3a5eac3deb081217aaf608.tar.bz2
gentoo-cef788711865f86dec3a5eac3deb081217aaf608.zip
dev-cpp/cpp-hocon: 0.3.0 bump
may help fix Bug: https://bugs.gentoo.org/727372 Package-Manager: Portage-2.3.99, Repoman-2.3.23 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-cpp/cpp-hocon/cpp-hocon-0.3.0.ebuild')
-rw-r--r--dev-cpp/cpp-hocon/cpp-hocon-0.3.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-cpp/cpp-hocon/cpp-hocon-0.3.0.ebuild b/dev-cpp/cpp-hocon/cpp-hocon-0.3.0.ebuild
new file mode 100644
index 000000000000..082eef626412
--- /dev/null
+++ b/dev-cpp/cpp-hocon/cpp-hocon-0.3.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Provides C++ support for the HOCON configuration file format"
+HOMEPAGE="https://github.com/puppetlabs/cpp-hocon"
+SRC_URI="https://github.com/puppetlabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug"
+
+DEPEND="
+ >=dev-libs/boost-1.54:=[nls]
+ >=dev-libs/leatherman-0.9.3:=
+ "
+RDEPEND="${DEPEND}"
+
+#PATCHES=( "${FILESDIR}"/${PN}-0.2.1-cmake.patch )