summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2021-05-10 17:42:06 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-05-21 16:52:15 +0200
commit2bc200d5c47a9bf0cf269feba2e0b5f84098e738 (patch)
tree28902ec6b92cdc275514d9ca0551aec274a1a2c5 /dev-cpp/eigen/files
parentapp-admin/perl-cleaner: Remove old (diff)
downloadgentoo-2bc200d5c47a9bf0cf269feba2e0b5f84098e738.tar.gz
gentoo-2bc200d5c47a9bf0cf269feba2e0b5f84098e738.tar.bz2
gentoo-2bc200d5c47a9bf0cf269feba2e0b5f84098e738.zip
dev-cpp/eigen: remove unused patch
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/20755 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-cpp/eigen/files')
-rw-r--r--dev-cpp/eigen/files/eigen-3.3.8-no-error-counting-in-openmp-parallelize_gemm.patch64
1 files changed, 0 insertions, 64 deletions
diff --git a/dev-cpp/eigen/files/eigen-3.3.8-no-error-counting-in-openmp-parallelize_gemm.patch b/dev-cpp/eigen/files/eigen-3.3.8-no-error-counting-in-openmp-parallelize_gemm.patch
deleted file mode 100644
index 556474e8b310..000000000000
--- a/dev-cpp/eigen/files/eigen-3.3.8-no-error-counting-in-openmp-parallelize_gemm.patch
+++ /dev/null
@@ -1,64 +0,0 @@
-From ef3cc72cb65e2d500459c178c63e349bacfa834f Mon Sep 17 00:00:00 2001
-From: Luke Peterson <hazelnusse@gmail.com>
-Date: Thu, 8 Oct 2020 12:16:53 -0700
-Subject: [PATCH] Remove error counting in OpenMP parallelize_gemm
-
-This resolves a compilation error associated with
-Eigen::eigen_assert_exception. It also eliminates the counting of
-exceptions that may occur in the OpenMP parallel section. If an
-unhandled exception occurs in this section, the behavior is non-conforming
-according to the OpenMP specification.
----
- Eigen/src/Core/products/Parallelizer.h | 14 +++++---------
- test/CMakeLists.txt | 2 +-
- 2 files changed, 6 insertions(+), 10 deletions(-)
-
-diff --git a/Eigen/src/Core/products/Parallelizer.h b/Eigen/src/Core/products/Parallelizer.h
-index 67b2442b5..a3cc05b77 100644
---- a/Eigen/src/Core/products/Parallelizer.h
-+++ b/Eigen/src/Core/products/Parallelizer.h
-@@ -132,8 +132,7 @@ void parallelize_gemm(const Functor& func, Index rows, Index cols, Index depth,
-
- ei_declare_aligned_stack_constructed_variable(GemmParallelInfo<Index>,info,threads,0);
-
-- int errorCount = 0;
-- #pragma omp parallel num_threads(threads) reduction(+: errorCount)
-+ #pragma omp parallel num_threads(threads)
- {
- Index i = omp_get_thread_num();
- // Note that the actual number of threads might be lower than the number of request ones.
-@@ -152,14 +151,11 @@ void parallelize_gemm(const Functor& func, Index rows, Index cols, Index depth,
- info[i].lhs_start = r0;
- info[i].lhs_length = actualBlockRows;
-
-- EIGEN_TRY {
-- if(transpose) func(c0, actualBlockCols, 0, rows, info);
-- else func(0, rows, c0, actualBlockCols, info);
-- } EIGEN_CATCH(...) {
-- ++errorCount;
-- }
-+ if(transpose)
-+ func(c0, actualBlockCols, 0, rows, info);
-+ else
-+ func(0, rows, c0, actualBlockCols, info);
- }
-- if (errorCount) EIGEN_THROW_X(Eigen::eigen_assert_exception());
- #endif
- }
-
-diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
-index 0747aa6cb..b02577780 100644
---- a/test/CMakeLists.txt
-+++ b/test/CMakeLists.txt
-@@ -163,7 +163,7 @@ ei_add_test(constructor)
- ei_add_test(linearstructure)
- ei_add_test(integer_types)
- ei_add_test(unalignedcount)
--if(NOT EIGEN_TEST_NO_EXCEPTIONS)
-+if(NOT EIGEN_TEST_NO_EXCEPTIONS AND NOT EIGEN_TEST_OPENMP)
- ei_add_test(exceptions)
- endif()
- ei_add_test(redux)
---
-GitLab
-