summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-07-21 15:21:45 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-07-21 17:50:12 +0200
commitd402f6a2790e3383890aefc340ff7e0b96cee949 (patch)
tree7bdadd8eef7327e70eca762fbfeb870dd9cc1ec6 /dev-cpp/eigen/files
parentprofiles: ia64/sparc: Drop obsolete dev-cpp/eigen[test] p.use.mask (diff)
downloadgentoo-d402f6a2790e3383890aefc340ff7e0b96cee949.tar.gz
gentoo-d402f6a2790e3383890aefc340ff7e0b96cee949.tar.bz2
gentoo-d402f6a2790e3383890aefc340ff7e0b96cee949.zip
dev-cpp/eigen: EAPI-7 bump, switch to cmake.eclass
- Update HOMEPAGE - Drop IUSE="c++11", build was broken anyway with it disabled - Drop obsolete slot 0 blocker - Sort dependencies - Drop useless src_unpack(), just define ${S} instead - Properly configure CMAKEPACKAGE_INSTALL_DIR instead of manual doins - configure in src_configure, compile in src_compile, drop src_test() - Drop obsolete -g2 removal - Consolidate and improve conditional !test seds - Replace CMAKE_BUILD_TYPE override sed with patch - Change FindEigen3.cmake module install path Package-Manager: Portage-3.0.0, Repoman-2.3.23 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-cpp/eigen/files')
-rw-r--r--dev-cpp/eigen/files/eigen-3.3.7-gentoo-cmake.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-cpp/eigen/files/eigen-3.3.7-gentoo-cmake.patch b/dev-cpp/eigen/files/eigen-3.3.7-gentoo-cmake.patch
new file mode 100644
index 000000000000..0389cd3b9333
--- /dev/null
+++ b/dev-cpp/eigen/files/eigen-3.3.7-gentoo-cmake.patch
@@ -0,0 +1,24 @@
+Let us properly override with CMAKE_BUILD_TYPE=Gentoo
+
+--- a/CMakeLists.txt 2018-12-11 18:57:55.000000000 +0100
++++ b/CMakeLists.txt 2020-07-21 16:43:33.467680534 +0200
+@@ -14,18 +14,7 @@
+ set(Eigen_BINARY_DIR ${Eigen3_BINARY_DIR})
+
+ # guard against bad build-type strings
+-
+-if (NOT CMAKE_BUILD_TYPE)
+- set(CMAKE_BUILD_TYPE "Release")
+-endif()
+-
+-string(TOLOWER "${CMAKE_BUILD_TYPE}" cmake_build_type_tolower)
+-if( NOT cmake_build_type_tolower STREQUAL "debug"
+- AND NOT cmake_build_type_tolower STREQUAL "release"
+- AND NOT cmake_build_type_tolower STREQUAL "relwithdebinfo")
+- message(FATAL_ERROR "Unknown build type \"${CMAKE_BUILD_TYPE}\". Allowed values are Debug, Release, RelWithDebInfo (case-insensitive).")
+-endif()
+-
++# yeah no.
+
+ #############################################################################
+ # retrieve version infomation #