summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-05-07 11:25:43 -0700
committerMatt Turner <mattst88@gentoo.org>2021-05-07 11:30:10 -0700
commita0a02730edf14db9edfb69e442841dd654aadf99 (patch)
tree3c3abc321f3f280f48cbd69c3ded5200d43b9ce2 /dev-cpp/glibmm/glibmm-2.66.0.ebuild
parentdev-perl/Crypt-CBC: Version bump 3.03 (diff)
downloadgentoo-a0a02730edf14db9edfb69e442841dd654aadf99.tar.gz
gentoo-a0a02730edf14db9edfb69e442841dd654aadf99.tar.bz2
gentoo-a0a02730edf14db9edfb69e442841dd654aadf99.zip
dev-cpp/glibmm: Version bump to 2.66.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-cpp/glibmm/glibmm-2.66.0.ebuild')
-rw-r--r--dev-cpp/glibmm/glibmm-2.66.0.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/dev-cpp/glibmm/glibmm-2.66.0.ebuild b/dev-cpp/glibmm/glibmm-2.66.0.ebuild
new file mode 100644
index 000000000000..25300c2afb5d
--- /dev/null
+++ b/dev-cpp/glibmm/glibmm-2.66.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+inherit gnome.org meson multilib-minimal python-any-r1
+
+DESCRIPTION="C++ interface for glib2"
+HOMEPAGE="https://www.gtkmm.org"
+
+LICENSE="LGPL-2.1+"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+IUSE="doc debug test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/libsigc++-2.9.1:2[${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.61.2:2[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+ >=dev-cpp/mm-common-1.0.0
+ sys-devel/m4
+ dev-lang/perl
+ doc? (
+ app-doc/doxygen
+ dev-libs/libxslt
+ media-gfx/graphviz
+ )
+"
+
+src_prepare() {
+ default
+
+ # giomm_tls_client requires FEATURES=-network-sandbox and glib-networking rdep
+ sed -i -e '/giomm_tls_client/d' tests/meson.build || die
+
+ if ! use test; then
+ sed -i -e "/^subdir('tests')/d" meson.build || die
+ fi
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dmaintainer-mode=true # Set false and drop mm-common dep once tarballs are made with meson/ninja
+ -Dwarnings=min
+ -Dbuild-deprecated-api=true
+ -Dbuild-documentation=$(usex doc true false)
+ -Ddebug-refcounting=$(usex debug true false)
+ -Dbuild-examples=false
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_test() {
+ meson_src_test
+}
+
+multilib_src_install() {
+ meson_src_install
+}