summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-12-03 20:26:25 -0500
committerMatt Turner <mattst88@gentoo.org>2022-12-03 21:36:52 -0500
commitbfa6508a0bc5810f33c0f43acb56f70d9fbb32e1 (patch)
tree1d5651d56de762518968ce727ee073309db46777 /dev-cpp/glibmm/glibmm-2.66.4-r1.ebuild
parentdev-cpp/cairomm: Drop old versions (diff)
downloadgentoo-bfa6508a0bc5810f33c0f43acb56f70d9fbb32e1.tar.gz
gentoo-bfa6508a0bc5810f33c0f43acb56f70d9fbb32e1.tar.bz2
gentoo-bfa6508a0bc5810f33c0f43acb56f70d9fbb32e1.zip
dev-cpp/glibmm: Drop old versions
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-cpp/glibmm/glibmm-2.66.4-r1.ebuild')
-rw-r--r--dev-cpp/glibmm/glibmm-2.66.4-r1.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/dev-cpp/glibmm/glibmm-2.66.4-r1.ebuild b/dev-cpp/glibmm/glibmm-2.66.4-r1.ebuild
deleted file mode 100644
index 499f1f67901f..000000000000
--- a/dev-cpp/glibmm/glibmm-2.66.4-r1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
-inherit gnome.org meson-multilib python-any-r1
-
-DESCRIPTION="C++ interface for glib2"
-HOMEPAGE="https://www.gtkmm.org https://gitlab.gnome.org/GNOME/glibmm"
-
-LICENSE="LGPL-2.1+"
-SLOT="2"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
-IUSE="gtk-doc debug test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-libs/libsigc++-2.9.1:2[${MULTILIB_USEDEP}]
- >=dev-libs/glib-2.61.2:2[${MULTILIB_USEDEP}]
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- ${PYTHON_DEPS}
- virtual/pkgconfig
- gtk-doc? (
- app-doc/doxygen[dot]
- dev-lang/perl
- dev-perl/XML-Parser
- dev-libs/libxslt
- media-gfx/graphviz
- )
-"
-
-src_prepare() {
- default
-
- # giomm_tls_client requires FEATURES=-network-sandbox and glib-networking rdep
- sed -i -e '/giomm_tls_client/d' tests/meson.build || die
-
- if ! use test; then
- sed -i -e "/^subdir('tests')/d" meson.build || die
- fi
-}
-
-multilib_src_configure() {
- local emesonargs=(
- -Dwarnings=min
- -Dbuild-deprecated-api=true
- $(meson_native_use_bool gtk-doc build-documentation)
- $(meson_use debug debug-refcounting)
- -Dbuild-examples=false
- )
- meson_src_configure
-}