summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-11-16 22:12:32 +0100
committerPacho Ramos <pacho@gentoo.org>2015-11-16 22:55:27 +0100
commit9ce0ce7932eefcede167afb6704d62102390126a (patch)
treec295f05e50c35a0b4ad01b63278574ac8658eb2c /dev-cpp/glibmm
parentdev-cpp/atkmm: Drop old (diff)
downloadgentoo-9ce0ce7932eefcede167afb6704d62102390126a.tar.gz
gentoo-9ce0ce7932eefcede167afb6704d62102390126a.tar.bz2
gentoo-9ce0ce7932eefcede167afb6704d62102390126a.zip
dev-cpp/glibmm: Version bump
Package-Manager: portage-2.2.24
Diffstat (limited to 'dev-cpp/glibmm')
-rw-r--r--dev-cpp/glibmm/Manifest1
-rw-r--r--dev-cpp/glibmm/glibmm-2.46.1.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/dev-cpp/glibmm/Manifest b/dev-cpp/glibmm/Manifest
index dd06aa3a0584..9fbb96514775 100644
--- a/dev-cpp/glibmm/Manifest
+++ b/dev-cpp/glibmm/Manifest
@@ -1,3 +1,4 @@
DIST glibmm-2.40.0.tar.xz 5645840 SHA256 34f320fad7e0057c63863706caa802ae0051b21523bed91ec33baf8421ca484f SHA512 3a51b3e311ba59505b3c452afdfdf456f184c39651d81317ff62f942d309f8707306cc68c69c20f7534f585036086088159414c7e75de59ab2684c4850559cb9 WHIRLPOOL 876ac86023e41b281408bf5435e32cd7674c2db1f92910508a082c8b316651b9e612de431ff767bffe4cd0613bb03a040e7569198cf3dc607f572cbcf5198bb2
DIST glibmm-2.42.0.tar.xz 6031860 SHA256 985083d97378d234da27a7243587cc0d186897a4b2d3c1286f794089be1a3397 SHA512 63bac04bf288d90f40d8bd08d16e147a42e2293a99998fabdc83bf1ef8a50197e44d95c1608f93fe7f2a1a791dd624dffb2db4426d3eaf32ce0f75ddac3559fb WHIRLPOOL 644b9446907066b20695ae9d848633b73aa30adff43d7c08f7afe002670cfac96a7e98d9669d35721c1f41fd2efb1ebc03d84ae1bdd3147f32e5a70ad3d099ea
DIST glibmm-2.44.0.tar.xz 6102664 SHA256 1b0ac0425d24895507c0e0e8088a464c7ae2d289c47afa1c11f63278fc672ea8 SHA512 4a932b127ce0ed0798cef3555fdd1ca1632fc10720b74f9a39626989c216542807d76ae67ebc980049b65b1c163d236fc9875506ca2d80584c724394bbb8bfd7 WHIRLPOOL d1fad56af4487e661398ec3be006c528c5c6c1cba0181ad08725f14cb94bbbfe2f9c20870722b90ebca61a51e9959eee89b1f92a7f00f99bc3a573b123360197
+DIST glibmm-2.46.1.tar.xz 6470952 SHA256 9647e596c1081d2ea202bd3da2824ec2ea359498fa86eb59a55b1b307dd8c4aa SHA512 4209264ec40e8894d3b4876f65af1458b6a15e22e3069058bf7f32854b5150a1890359cee878d29de94f609e423dc6f8467cffbbecf4a30d5810c890ad40b981 WHIRLPOOL 909a283d06e45e6d4077f0058eaa884acc268a93d97d80009f81cd91f3b8e73dd0016e7071797a1e9e95775752673fd6b47e295c58338052a0976054278964e7
diff --git a/dev-cpp/glibmm/glibmm-2.46.1.ebuild b/dev-cpp/glibmm/glibmm-2.46.1.ebuild
new file mode 100644
index 000000000000..b85daf669d8c
--- /dev/null
+++ b/dev-cpp/glibmm/glibmm-2.46.1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2 multilib-minimal
+
+DESCRIPTION="C++ interface for glib2"
+HOMEPAGE="http://www.gtkmm.org"
+
+LICENSE="LGPL-2.1+ GPL-2+" # GPL-2+ applies only to the build system
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="doc debug examples test"
+
+RDEPEND="
+ >=dev-libs/libsigc++-2.6.0:2[${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.46.0:2[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+# dev-cpp/mm-common needed for eautoreconf
+
+src_prepare() {
+ if ! use test; then
+ # don't waste time building tests
+ sed 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' \
+ -i Makefile.am Makefile.in || die "sed 1 failed"
+ fi
+
+ # don't build examples - we want to install example sources, not binaries
+ sed 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' \
+ -i Makefile.am Makefile.in || die "sed 2 failed"
+
+ # Test fails with IPv6 but not v4, upstream bug #720073
+# sed -e 's:giomm_tls_client/test::' \
+# -i tests/Makefile.{am,in} || die
+
+ gnome2_src_prepare
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" gnome2_src_configure \
+ $(use_enable debug debug-refcounting) \
+ $(multilib_native_use_enable doc documentation) \
+ --enable-deprecated-api
+}
+
+multilib_src_test() {
+ cd tests
+ default
+
+ for i in */test; do
+ ${i} || die "Running tests failed at ${i}"
+ done
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ if ! use doc && ! use examples; then
+ rm -fr "${ED}usr/share/doc/glibmm*"
+ fi
+
+ if use examples; then
+ find examples -type d -name '.deps' -exec rm -rf {} \; 2>/dev/null
+ dodoc -r examples
+ fi
+}