summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-08-11 19:20:07 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-08-11 19:20:20 +0200
commit37574dffd48a81837afe5b0ac9eeb8845572e642 (patch)
tree2895bae8994b06bc4740d3d0860453649b0a3abd /dev-cpp/glog
parentdev-cpp/glog: x86 stable (bug #555030) (diff)
downloadgentoo-37574dffd48a81837afe5b0ac9eeb8845572e642.tar.gz
gentoo-37574dffd48a81837afe5b0ac9eeb8845572e642.tar.bz2
gentoo-37574dffd48a81837afe5b0ac9eeb8845572e642.zip
dev-cpp/glog: drop old
Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-cpp/glog')
-rw-r--r--dev-cpp/glog/Manifest1
-rw-r--r--dev-cpp/glog/glog-0.3.3-r1.ebuild64
-rw-r--r--dev-cpp/glog/glog-0.3.4.ebuild65
3 files changed, 0 insertions, 130 deletions
diff --git a/dev-cpp/glog/Manifest b/dev-cpp/glog/Manifest
index 76e694662c0f..ee282632ddc0 100644
--- a/dev-cpp/glog/Manifest
+++ b/dev-cpp/glog/Manifest
@@ -1,4 +1,3 @@
-DIST glog-0.3.3.tar.gz 509676 BLAKE2B 21d8893ff535c0e8c1de27214f535aaea99727128d80f421da096969c19504da6a296054db2931232b4fd372446f96189464e4000f44c5720152085aa9976978 SHA512 95418ff0857415a0fbc15caeb22a13f3b6736618adcc3c30e054626f1397bc58399c45f68784c70b1f5dc594ebc6ea66e386896beab5c20be72dd53b25f5a4ac
DIST glog-0.3.4.tar.gz 522508 BLAKE2B 4a188d5998005b29afc52f2ea548f33e06a68da993bb74960e5aedb214ec52ef9e9fc39efb1a34f38f217b92df7db064ff01d58df36c3e4ad789becc97335ec2 SHA512 139525b546a9eccacc9bebf7cc3053ba52229e9488485ad45344c3d3134ca819d3b571250c0e3a6d84097009c8be89b0f4fa16ef5ec838ffcc237ae11c3a034c
DIST glog-0.3.5.tar.gz 532275 BLAKE2B a455f3ff8fc7cf2861a4351a0305db9455bb79977e57c49b6269b3fa2c147cd9627bfaf4c7aaa04fe4a49158d79abeb5b985813fe8c473d6005e915335c0d693 SHA512 a54a3b8b4b7660d7558ba5168c659bc3c8323c30908a4f6a4bbc6f9cd899350f3243aabc720daebfdeb799b276b51ba1eaa1a0f83149c4e1a038d552ada1ed72
DIST glog-0.4.0.tar.gz 200955 BLAKE2B 083da6117af3e85697724942bfcb5a7831d447666945b06b149d8d324231b10923887bd8c507e8027136d12bffd30a657cb225df8c449f234381e3876f132953 SHA512 b585f1819ade2075f6b61dc5aaca5c3f9d25601dba2bd08b6c49b96ac5f79db23c6b7f2042df003f7130497dd7241fcaa8b107d1f97385cb66ce52d3c554b176
diff --git a/dev-cpp/glog/glog-0.3.3-r1.ebuild b/dev-cpp/glog/glog-0.3.3-r1.ebuild
deleted file mode 100644
index 667d65726491..000000000000
--- a/dev-cpp/glog/glog-0.3.3-r1.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="4"
-inherit eutils multilib-minimal
-
-DESCRIPTION="Google's C++ logging library"
-HOMEPAGE="https://github.com/google/glog"
-SRC_URI="https://google-glog.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ppc64 ~s390 ~sh ~sparc x86 ~amd64-linux ~x86-linux"
-IUSE="gflags static-libs unwind test"
-
-RDEPEND="gflags? ( >=dev-cpp/gflags-2.0-r1[${MULTILIB_USEDEP}] )
- unwind? ( sys-libs/libunwind )"
-DEPEND="${RDEPEND}
- test? ( >=dev-cpp/gtest-1.8.0[${MULTILIB_USEDEP}] )"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-0.3.2-avoid-inline-asm.patch
- # Fix the --dodcdir flag:
- # https://code.google.com/p/google-glog/issues/detail?id=193
- sed -i \
- -e '/^docdir =/s:=.*:= @docdir@:' \
- Makefile.in || die
-}
-
-multilib_src_configure() {
- use test || export ac_cv_prog_GTEST_CONFIG=no
- ECONF_SOURCE=${S} \
- ac_cv_lib_gflags_main=$(usex gflags) \
- ac_cv_lib_unwind_backtrace=$(usex unwind) \
- econf \
- --docdir="\$(datarootdir)/doc/${PF}" \
- --htmldir='$(docdir)/html' \
- $(use_enable static-libs static)
-}
-
-_emake() {
- # The tests always get built ... disable them when unused.
- emake $(usex test '' noinst_PROGRAMS=) "$@"
-}
-
-multilib_src_compile() {
- _emake
-}
-
-multilib_src_install() {
- _emake install DESTDIR="${D}"
-}
-
-multilib_src_install_all() {
- # Punt docs we don't care about (NEWS is 0 bytes).
- rm "${ED}"/usr/share/doc/${PF}/{COPYING,NEWS,README.windows} || die
-
- # --htmldir doesn't work (yet):
- # https://code.google.com/p/google-glog/issues/detail?id=144
- dohtml "${ED}"/usr/share/doc/${PF}/*
- rm "${ED}"/usr/share/doc/${PF}/*.{html,css}
-
- use static-libs || find "${ED}" -name '*.la' -delete
-}
diff --git a/dev-cpp/glog/glog-0.3.4.ebuild b/dev-cpp/glog/glog-0.3.4.ebuild
deleted file mode 100644
index a6b6ee4e3fb4..000000000000
--- a/dev-cpp/glog/glog-0.3.4.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit eutils multilib-minimal
-
-DESCRIPTION="Google's C++ logging library"
-HOMEPAGE="https://github.com/google/glog"
-SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="gflags static-libs unwind test"
-
-RDEPEND="gflags? ( >=dev-cpp/gflags-2.0-r1[${MULTILIB_USEDEP}] )
- unwind? ( sys-libs/libunwind )"
-DEPEND="${RDEPEND}
- test? ( >=dev-cpp/gtest-1.8.0[${MULTILIB_USEDEP}] )"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-0.3.2-avoid-inline-asm.patch
- # Fix the --dodcdir flag:
- # https://code.google.com/p/google-glog/issues/detail?id=193
- sed -i \
- -e '/^docdir =/s:=.*:= @docdir@:' \
- Makefile.in || die
-}
-
-multilib_src_configure() {
- use test || export ac_cv_prog_GTEST_CONFIG=no
- ECONF_SOURCE=${S} \
- ac_cv_lib_gflags_main=$(usex gflags) \
- ac_cv_lib_unwind_backtrace=$(usex unwind) \
- econf \
- --docdir="\$(datarootdir)/doc/${PF}" \
- --htmldir='$(docdir)/html' \
- $(use_enable static-libs static)
-}
-
-_emake() {
- # The tests always get built ... disable them when unused.
- emake $(usex test '' noinst_PROGRAMS=) "$@"
-}
-
-multilib_src_compile() {
- _emake
-}
-
-multilib_src_install() {
- _emake install DESTDIR="${D}"
-}
-
-multilib_src_install_all() {
- # Punt docs we don't care about (NEWS is 0 bytes).
- rm "${ED}"/usr/share/doc/${PF}/{COPYING,NEWS,README.windows} || die
-
- # --htmldir doesn't work (yet):
- # https://code.google.com/p/google-glog/issues/detail?id=144
- dohtml "${ED}"/usr/share/doc/${PF}/*
- rm "${ED}"/usr/share/doc/${PF}/*.{html,css}
-
- use static-libs || find "${ED}" -name '*.la' -delete
-}