summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Henke <Jan.Henke@taujhe.de>2018-01-08 20:28:24 +0100
committerCraig Andrews <candrews@gentoo.org>2018-01-08 14:57:56 -0500
commit07c63b0b1358df3fc474a140b3b39a4cb6ff6bf2 (patch)
tree57e1976e06a8bf21905882c4c1bc684174334c29 /dev-cpp/gsl
parentdev-python/pypy3-bin: Remove unused USE=doc code (diff)
downloadgentoo-07c63b0b1358df3fc474a140b3b39a4cb6ff6bf2.tar.gz
gentoo-07c63b0b1358df3fc474a140b3b39a4cb6ff6bf2.tar.bz2
gentoo-07c63b0b1358df3fc474a140b3b39a4cb6ff6bf2.zip
dev-cpp/gsl: New git snapshot and correctly patch catch use
This updates the ebuild to a more recent snapshot and also fixes the patching to use the system wide catch instead of downloading it during build. Closes: https://bugs.gentoo.org/643422 Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'dev-cpp/gsl')
-rw-r--r--dev-cpp/gsl/Manifest1
-rw-r--r--dev-cpp/gsl/files/gsl-0_pre20180108-use_system_catch-636828.patch21
-rw-r--r--dev-cpp/gsl/gsl-0_pre20180108.ebuild31
-rw-r--r--dev-cpp/gsl/metadata.xml2
4 files changed, 54 insertions, 1 deletions
diff --git a/dev-cpp/gsl/Manifest b/dev-cpp/gsl/Manifest
index eb36ecd5112e..601be068e061 100644
--- a/dev-cpp/gsl/Manifest
+++ b/dev-cpp/gsl/Manifest
@@ -1 +1,2 @@
DIST gsl-0_pre20171105.tar.gz 55870 BLAKE2B cc26a8a304a65cd6a487d22369b5b23169e07144a7629388fffdbf263619c0849f00efcc1a072408e3e89dd933e3309c15049d0fec30de07267b5b693c5c9657 SHA512 0db9cae9af710c45f66d1e2b73e2002f921876d400165d13dbe9ede7aa9335249458a9f97d4eda4cff0b3a5ceebb6ef84b631310921011fedee8776fcec89e6a
+DIST gsl-0_pre20180108.tar.gz 57335 BLAKE2B 7221828d433dfe13e500b57b1da5b828aadc95b0c210327dd25713ce7f5b0629a7067cd8ed2ef30e11c8b8a58fa424b1edc3d374440770ee814c4c3e372038d6 SHA512 7684c8ae7ad9d0624d2f1e3531b942e7a98960f60698e4c212998ddc2ac4651fccfe5fea66d1a22133b9cba4567ba4253b022f8826f069d2e2633b3074d4f640
diff --git a/dev-cpp/gsl/files/gsl-0_pre20180108-use_system_catch-636828.patch b/dev-cpp/gsl/files/gsl-0_pre20180108-use_system_catch-636828.patch
new file mode 100644
index 000000000000..12d92605dda8
--- /dev/null
+++ b/dev-cpp/gsl/files/gsl-0_pre20180108-use_system_catch-636828.patch
@@ -0,0 +1,21 @@
+Add CMake option to disable upstream's catch download, we always want to use the
+system wide installed version. Gentoo bug 636828.
+
+diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
+index 86ce5a4..b36df56 100644
+--- a/tests/CMakeLists.txt
++++ b/tests/CMakeLists.txt
+@@ -10,7 +10,9 @@ list(APPEND CATCH_CMAKE_ARGS
+ "-DNO_SELFTEST=true"
+ )
+
+-if(GIT_FOUND)
++option(FORCE_SYSTEM_CATCH "Force usage of system-wide catch install" OFF)
++
++if(NOT ${FORCE_SYSTEM_CATCH} AND GIT_FOUND)
+ # add catch
+ ExternalProject_Add(
+ catch
+--
+2.13.6
+
diff --git a/dev-cpp/gsl/gsl-0_pre20180108.ebuild b/dev-cpp/gsl/gsl-0_pre20180108.ebuild
new file mode 100644
index 000000000000..95ee05e9cd36
--- /dev/null
+++ b/dev-cpp/gsl/gsl-0_pre20180108.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils vcs-snapshot
+
+DESCRIPTION="Guideline Support Library implementation by Microsoft"
+HOMEPAGE="https://github.com/Microsoft/GSL"
+SRC_URI="https://github.com/Microsoft/${PN}/tarball/9d65e74400976b3509833f49b16d401600c7317d -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# header only library
+RDEPEND=""
+DEPEND="test? ( >=dev-cpp/catch-1.11.0 )"
+
+PATCHES=(
+ "${FILESDIR}/${P}-use_system_catch-636828.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DGSL_TEST=$(usex test)
+ -DFORCE_SYSTEM_CATCH=ON
+ )
+ cmake-utils_src_configure
+}
diff --git a/dev-cpp/gsl/metadata.xml b/dev-cpp/gsl/metadata.xml
index 57bf76b92106..b1f7b8de77fb 100644
--- a/dev-cpp/gsl/metadata.xml
+++ b/dev-cpp/gsl/metadata.xml
@@ -3,7 +3,7 @@
<pkgmetadata>
<maintainer type="person">
<email>gentoo@taujhe.de</email>
- <description>Jan Henke</description>
+ <name>Jan Henke</name>
</maintainer>
<maintainer type="project">
<email>proxy-maint@gentoo.org</email>