summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-30 20:12:17 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-31 19:42:20 +0100
commitbe0ab352405aa2d5d968a8c3905557b914df9626 (patch)
tree5b5da6a6ab8feb0c82b1f5c6b02e9fafdee83463 /dev-cpp/gtest/gtest-1.10.0.ebuild
parentsys-kernel/gentoo-sources: Linux patch 5.4.7 (diff)
downloadgentoo-be0ab352405aa2d5d968a8c3905557b914df9626.tar.gz
gentoo-be0ab352405aa2d5d968a8c3905557b914df9626.tar.bz2
gentoo-be0ab352405aa2d5d968a8c3905557b914df9626.zip
*/*: Switch proxy-maint to cmake.eclass
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-cpp/gtest/gtest-1.10.0.ebuild')
-rw-r--r--dev-cpp/gtest/gtest-1.10.0.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-cpp/gtest/gtest-1.10.0.ebuild b/dev-cpp/gtest/gtest-1.10.0.ebuild
index 98d67d92032c..ea624a4fe89b 100644
--- a/dev-cpp/gtest/gtest-1.10.0.ebuild
+++ b/dev-cpp/gtest/gtest-1.10.0.ebuild
@@ -5,7 +5,7 @@ EAPI=7
# Python is required for tests and some build tasks.
PYTHON_COMPAT=( python2_7 pypy )
-
+CMAKE_ECLASS=cmake
inherit cmake-multilib python-any-r1
MY_PV=1.10.x
@@ -44,7 +44,7 @@ pkg_setup() {
}
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
sed -i -e '/set(cxx_base_flags /s:-Werror::' \
googletest/cmake/internal_utils.cmake || die "sed failed!"
@@ -60,7 +60,7 @@ multilib_src_configure() {
-Dgtest_build_tests=$(usex test)
-DPYTHON_EXECUTABLE="${PYTHON}"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
multilib_src_install_all() {