summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Levine <plevine457@gmail.com>2017-10-09 01:14:30 -0400
committerMike Gilbert <floppym@gentoo.org>2018-01-09 11:10:00 -0500
commitcd6ac5d6bb69df16d76548f12eed0e0db5daf073 (patch)
tree9d181373d2abbb72f83d4bf6cda4ce100523e8a7 /dev-cpp/gtest
parentdev-cpp/gtest: Fix test failure with sandbox (diff)
downloadgentoo-cd6ac5d6bb69df16d76548f12eed0e0db5daf073.tar.gz
gentoo-cd6ac5d6bb69df16d76548f12eed0e0db5daf073.tar.bz2
gentoo-cd6ac5d6bb69df16d76548f12eed0e0db5daf073.zip
dev-cpp/gtest: Support install of extra docs
Package-Manager: Portage-2.3.10, Repoman-2.3.3
Diffstat (limited to 'dev-cpp/gtest')
-rw-r--r--dev-cpp/gtest/gtest-1.8.0.ebuild9
-rw-r--r--dev-cpp/gtest/gtest-9999.ebuild9
2 files changed, 16 insertions, 2 deletions
diff --git a/dev-cpp/gtest/gtest-1.8.0.ebuild b/dev-cpp/gtest/gtest-1.8.0.ebuild
index afb24f111d5c..1091001188ee 100644
--- a/dev-cpp/gtest/gtest-1.8.0.ebuild
+++ b/dev-cpp/gtest/gtest-1.8.0.ebuild
@@ -15,7 +15,7 @@ SRC_URI="https://github.com/google/googletest/archive/release-${PV}.tar.gz -> ${
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="examples test"
+IUSE="doc examples test"
DEPEND="test? ( ${PYTHON_DEPS} )"
RDEPEND="!dev-cpp/gmock"
@@ -53,6 +53,13 @@ multilib_src_configure() {
multilib_src_install_all() {
einstalldocs
+ if use doc; then
+ docinto googletest
+ dodoc -r googletest/docs/*
+ docinto googlemock
+ dodoc -r googlemock/docs/*
+ fi
+
if use examples; then
docinto examples
dodoc googletest/samples/*.{cc,h}
diff --git a/dev-cpp/gtest/gtest-9999.ebuild b/dev-cpp/gtest/gtest-9999.ebuild
index 79195676d089..a2c14fe23fd6 100644
--- a/dev-cpp/gtest/gtest-9999.ebuild
+++ b/dev-cpp/gtest/gtest-9999.ebuild
@@ -22,7 +22,7 @@ HOMEPAGE="https://github.com/google/googletest"
LICENSE="BSD"
SLOT="0"
-IUSE="examples test"
+IUSE="doc examples test"
DEPEND="test? ( ${PYTHON_DEPS} )"
RDEPEND="!dev-cpp/gmock"
@@ -61,6 +61,13 @@ multilib_src_configure() {
multilib_src_install_all() {
einstalldocs
+ if use doc; then
+ docinto googletest
+ dodoc -r googletest/docs/*
+ docinto googlemock
+ dodoc -r googlemock/docs/*
+ fi
+
if use examples; then
docinto examples
dodoc googletest/samples/*.{cc,h}