summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2019-11-10 19:40:18 +0100
committerPacho Ramos <pacho@gentoo.org>2019-11-10 19:55:22 +0100
commit582ac29b4cc0a17a7c6e8a2b7ef1a54c979a7320 (patch)
tree57f3168bafae8618c47c4dc747568b96ac867bb0 /dev-cpp/gtkmm/gtkmm-3.24.2.ebuild
parentsys-devel/crossdev: drop block on sys-devel/crossdev-wrappers (diff)
downloadgentoo-582ac29b4cc0a17a7c6e8a2b7ef1a54c979a7320.tar.gz
gentoo-582ac29b4cc0a17a7c6e8a2b7ef1a54c979a7320.tar.bz2
gentoo-582ac29b4cc0a17a7c6e8a2b7ef1a54c979a7320.zip
dev-cpp/gtkmm: Bump to 3.24.2
Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'dev-cpp/gtkmm/gtkmm-3.24.2.ebuild')
-rw-r--r--dev-cpp/gtkmm/gtkmm-3.24.2.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/dev-cpp/gtkmm/gtkmm-3.24.2.ebuild b/dev-cpp/gtkmm/gtkmm-3.24.2.ebuild
new file mode 100644
index 000000000000..03ade614c9a4
--- /dev/null
+++ b/dev-cpp/gtkmm/gtkmm-3.24.2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2 multilib-minimal virtualx
+
+DESCRIPTION="C++ interface for GTK+"
+HOMEPAGE="https://www.gtkmm.org"
+
+LICENSE="LGPL-2.1+"
+SLOT="3.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+
+IUSE="aqua doc test wayland X"
+REQUIRED_USE="|| ( aqua wayland X )"
+
+RDEPEND="
+ >=dev-cpp/glibmm-2.54.0:2[${MULTILIB_USEDEP}]
+ >=x11-libs/gtk+-3.24.0:3[aqua?,wayland?,X?,${MULTILIB_USEDEP}]
+ >=x11-libs/gdk-pixbuf-2.35.5:2[${MULTILIB_USEDEP}]
+ >=dev-cpp/atkmm-2.24.2[${MULTILIB_USEDEP}]
+ >=dev-cpp/cairomm-1.12.0[${MULTILIB_USEDEP}]
+ >=dev-cpp/pangomm-2.38.2:1.4[${MULTILIB_USEDEP}]
+ >=dev-libs/libsigc++-2.3.2:2[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? (
+ media-gfx/graphviz
+ dev-libs/libxslt
+ app-doc/doxygen )
+"
+# eautoreconf needs mm-common
+
+src_prepare() {
+ if ! use test; then
+ # don't waste time building tests
+ sed 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' -i Makefile.am Makefile.in \
+ || die "sed 1 failed"
+ fi
+
+ # don't waste time building examples
+ sed 's/^\(SUBDIRS =.*\)demos\(.*\)$/\1\2/' -i Makefile.am Makefile.in \
+ || die "sed 2 failed"
+
+ gnome2_src_prepare
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" gnome2_src_configure \
+ --enable-api-atkmm \
+ $(multilib_native_use_enable doc documentation) \
+ $(use_enable aqua quartz-backend) \
+ $(use_enable wayland wayland-backend) \
+ $(use_enable X x11-backend)
+}
+
+multilib_src_test() {
+ virtx emake check
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ find demos -type d -name '.deps' -exec rm -rf {} \; 2>/dev/null
+ find demos -type f -name 'Makefile*' -exec rm -f {} \; 2>/dev/null
+ dodoc -r demos
+}