summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2016-09-17 10:52:38 +0100
committerJames Le Cuirot <chewi@gentoo.org>2016-09-17 10:53:33 +0100
commit0078e475737eeeda82e6c7a23a5f17dbb9af0b54 (patch)
tree3601a49ebab13e1f114997e4aef8f796005c9831 /dev-cpp/htmlcxx/htmlcxx-0.86.ebuild
parentdev-db/mysql-5.6.33-r0: add alpha keyword (diff)
downloadgentoo-0078e475737eeeda82e6c7a23a5f17dbb9af0b54.tar.gz
gentoo-0078e475737eeeda82e6c7a23a5f17dbb9af0b54.tar.bz2
gentoo-0078e475737eeeda82e6c7a23a5f17dbb9af0b54.zip
dev-cpp/htmlcxx: New package, required by lgogdownloader
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-cpp/htmlcxx/htmlcxx-0.86.ebuild')
-rw-r--r--dev-cpp/htmlcxx/htmlcxx-0.86.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-cpp/htmlcxx/htmlcxx-0.86.ebuild b/dev-cpp/htmlcxx/htmlcxx-0.86.ebuild
new file mode 100644
index 000000000000..efc022586155
--- /dev/null
+++ b/dev-cpp/htmlcxx/htmlcxx-0.86.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils multilib-minimal
+
+DESCRIPTION="A simple non-validating CSS 1 and HTML parser for C++"
+HOMEPAGE="http://htmlcxx.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+DEPEND="sys-devel/flex[${MULTILIB_USEDEP}]
+ virtual/yacc"
+
+PATCHES=(
+ "${FILESDIR}"/0001-strstream-is-deprecated-use-sstream-instead.patch
+ "${FILESDIR}"/0002-Update-css_syntax.y-for-use-with-less-ancient-Bison.patch
+)
+
+ECONF_SOURCE="${S}"
+
+multilib_src_configure() {
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ prune_libtool_files
+ einstalldocs
+}