summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-01-24 15:26:03 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-01-24 17:11:36 +0100
commit6c7fcad9c09760f68119873a6252ed02eab777d2 (patch)
treef2643ef18f8fc418809586ccc204790faec70b6c /dev-cpp/libcmis
parentdev-libs/librevenge: drop 0.0.4-r2 (diff)
downloadgentoo-6c7fcad9c09760f68119873a6252ed02eab777d2.tar.gz
gentoo-6c7fcad9c09760f68119873a6252ed02eab777d2.tar.bz2
gentoo-6c7fcad9c09760f68119873a6252ed02eab777d2.zip
dev-cpp/libcmis: drop 0.5.2-r1
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-cpp/libcmis')
-rw-r--r--dev-cpp/libcmis/libcmis-0.5.2-r1.ebuild68
1 files changed, 0 insertions, 68 deletions
diff --git a/dev-cpp/libcmis/libcmis-0.5.2-r1.ebuild b/dev-cpp/libcmis/libcmis-0.5.2-r1.ebuild
deleted file mode 100644
index 7bb0d2a1f925..000000000000
--- a/dev-cpp/libcmis/libcmis-0.5.2-r1.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-if [[ ${PV} = 9999 ]]; then
- EGIT_REPO_URI="https://github.com/tdf/libcmis.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/tdf/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 ~arm arm64 ~loong ~ppc64 x86 ~amd64-linux ~x86-linux"
-fi
-inherit autotools flag-o-matic
-
-DESCRIPTION="C++ client library for the CMIS interface"
-HOMEPAGE="https://github.com/tdf/libcmis"
-
-LICENSE="|| ( GPL-2 LGPL-2 MPL-1.1 )"
-SLOT="0.5"
-
-IUSE="man static-libs test tools"
-
-BDEPEND="
- virtual/pkgconfig
- man? (
- app-text/docbook2X
- dev-libs/libxslt
- )
- test? (
- dev-util/cppcheck
- dev-util/cppunit
- )
-"
-DEPEND="
- dev-libs/boost:=
- dev-libs/libxml2
- net-misc/curl
-"
-RDEPEND="${DEPEND}"
-
-RESTRICT="test"
-
-PATCHES=( "${FILESDIR}/${P}-icu-64.2.patch" )
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- # bug 618778
- append-cxxflags -std=c++14
-
- local myeconfargs=(
- --program-suffix=-$(ver_cut 1-2)
- --disable-werror
- $(use_with man)
- $(use_enable static-libs static)
- $(use_enable test tests)
- $(use_enable tools client)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
- find "${D}" -name '*.la' -delete || die
-}