summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-01-06 13:21:48 +0100
committerMichał Górny <mgorny@gentoo.org>2018-01-06 13:23:57 +0100
commitc91390d2662b1324a5b132e8b3d1a9d76b4d0075 (patch)
tree52d3d48f825f9bb6df3664af33a4966735e5255d /dev-cpp/libjson-rpc-cpp/libjson-rpc-cpp-9999.ebuild
parentmedia-sound/guayadeque: Remove linguas_* from IUSE. (diff)
downloadgentoo-c91390d2662b1324a5b132e8b3d1a9d76b4d0075.tar.gz
gentoo-c91390d2662b1324a5b132e8b3d1a9d76b4d0075.tar.bz2
gentoo-c91390d2662b1324a5b132e8b3d1a9d76b4d0075.zip
dev-cpp/libjson-rpc-cpp: Enable UNIX & TCP socket client/server
Closes: https://bugs.gentoo.org/643676
Diffstat (limited to 'dev-cpp/libjson-rpc-cpp/libjson-rpc-cpp-9999.ebuild')
-rw-r--r--dev-cpp/libjson-rpc-cpp/libjson-rpc-cpp-9999.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-cpp/libjson-rpc-cpp/libjson-rpc-cpp-9999.ebuild b/dev-cpp/libjson-rpc-cpp/libjson-rpc-cpp-9999.ebuild
index 7c78e3d2afc4..55ab0c1f82f2 100644
--- a/dev-cpp/libjson-rpc-cpp/libjson-rpc-cpp-9999.ebuild
+++ b/dev-cpp/libjson-rpc-cpp/libjson-rpc-cpp-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -35,6 +35,11 @@ src_configure() {
-DHTTP_SERVER=$(usex http-server)
-DREDIS_CLIENT=$(usex redis-client)
-DREDIS_SERVER=$(usex redis-server)
+ # they have no deps
+ -DTCP_SOCKET_CLIENT=ON
+ -DTCP_SOCKET_SERVER=ON
+ -DUNIX_DOMAIN_SOCKET_CLIENT=ON
+ -DUNIX_DOMAIN_SOCKET_SERVER=ON
# they are not installed
-DCOMPILE_EXAMPLES=OFF
-DCOMPILE_STUBGEN=$(usex stubgen)