summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-01-22 18:14:49 +0100
committerDavid Seifert <soap@gentoo.org>2017-01-22 18:15:09 +0100
commit5223573e6f288a71744b8e486108b94ee9b9ca7f (patch)
tree08b44c74fc249a43ec517205a2805762764fdbb7 /dev-cpp/libmcpp/libmcpp-2.7.2-r2.ebuild
parentdev-cpp/sparsehash: Bump to EAPI 6 (diff)
downloadgentoo-5223573e6f288a71744b8e486108b94ee9b9ca7f.tar.gz
gentoo-5223573e6f288a71744b8e486108b94ee9b9ca7f.tar.bz2
gentoo-5223573e6f288a71744b8e486108b94ee9b9ca7f.zip
dev-cpp/libmcpp: Bump to EAPI 6
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-cpp/libmcpp/libmcpp-2.7.2-r2.ebuild')
-rw-r--r--dev-cpp/libmcpp/libmcpp-2.7.2-r2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-cpp/libmcpp/libmcpp-2.7.2-r2.ebuild b/dev-cpp/libmcpp/libmcpp-2.7.2-r2.ebuild
new file mode 100644
index 000000000000..05ac2443e7dd
--- /dev/null
+++ b/dev-cpp/libmcpp/libmcpp-2.7.2-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+MY_P=${P/lib/}
+
+DESCRIPTION="A portable C++ preprocessor"
+HOMEPAGE="http://mcpp.sourceforge.net"
+SRC_URI="mirror://sourceforge/mcpp/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~x86 ~x86-linux ~x64-macos"
+IUSE="static-libs"
+
+DEPEND=""
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=( "${FILESDIR}"/${PN}-2.7.2-fix-build-system.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-mcpplib \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ if ! use static-libs; then
+ find "${D}" -name '*.la' -delete || die
+ fi
+}