summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2022-03-27 11:17:07 +1100
committerMark Wright <gienah@gentoo.org>2022-03-27 11:23:51 +1100
commit3d03e75f4c8c09002eb62d9849207de0e92f000a (patch)
tree212c6236bd0ce99dd66ac68f927cdf61885c0f36 /dev-cpp/libodb
parentdev-python/sphinx_ansible_theme: Revert "drop 0.8.0, 0.9.0" (diff)
downloadgentoo-3d03e75f4c8c09002eb62d9849207de0e92f000a.tar.gz
gentoo-3d03e75f4c8c09002eb62d9849207de0e92f000a.tar.bz2
gentoo-3d03e75f4c8c09002eb62d9849207de0e92f000a.zip
dev-cpp/libodb: Move config.install.chroot="${D}" to src_install.
Closes: https://bugs.gentoo.org/836043 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Mark Wright <gienah@gentoo.org>
Diffstat (limited to 'dev-cpp/libodb')
-rw-r--r--dev-cpp/libodb/files/build2-0.13.0-libcpp-undefined-symol-vtable-for-match_any_but_newline-exec.patch38
-rw-r--r--dev-cpp/libodb/libodb-2.5.0_beta19.ebuild7
2 files changed, 42 insertions, 3 deletions
diff --git a/dev-cpp/libodb/files/build2-0.13.0-libcpp-undefined-symol-vtable-for-match_any_but_newline-exec.patch b/dev-cpp/libodb/files/build2-0.13.0-libcpp-undefined-symol-vtable-for-match_any_but_newline-exec.patch
new file mode 100644
index 000000000000..00b685600c8e
--- /dev/null
+++ b/dev-cpp/libodb/files/build2-0.13.0-libcpp-undefined-symol-vtable-for-match_any_but_newline-exec.patch
@@ -0,0 +1,38 @@
+--- build2-toolchain-0.13.0-orig/build2/libbuild2/script/regex.cxx 2020-06-10 19:25:37.000000000 +1000
++++ build2-toolchain-0.13.0/build2/libbuild2/script/regex.cxx 2020-08-10 14:00:05.698012838 +1000
+@@ -5,6 +5,35 @@
+
+ #include <libbuild2/script/regex.hxx>
+
++#if defined(_LIBCPP_VERSION)
++template <>
++void
++std::__1::__match_any_but_newline<build2::script::regex::line_char>::__exec(__state& __s) const
++{
++ if (__s.__current_ != __s.__last_)
++ {
++ switch (*__s.__current_)
++ {
++ case '\r':
++ case '\n':
++ __s.__do_ = __state::__reject;
++ __s.__node_ = nullptr;
++ break;
++ default:
++ __s.__do_ = __state::__accept_and_consume;
++ ++__s.__current_;
++ __s.__node_ = this->first();
++ break;
++ }
++ }
++ else
++ {
++ __s.__do_ = __state::__reject;
++ __s.__node_ = nullptr;
++ }
++}
++#endif
++
+ using namespace std;
+
+ namespace build2
diff --git a/dev-cpp/libodb/libodb-2.5.0_beta19.ebuild b/dev-cpp/libodb/libodb-2.5.0_beta19.ebuild
index df3cbb7b3e1e..32154f060860 100644
--- a/dev-cpp/libodb/libodb-2.5.0_beta19.ebuild
+++ b/dev-cpp/libodb/libodb-2.5.0_beta19.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -45,6 +45,7 @@ b() {
src_prepare() {
pushd "${BS}" || die
eapply "${FILESDIR}"/build2-0.13.0_alpha0_pre20200710-nousrlocal.patch
+ eapply "${FILESDIR}"/build2-0.13.0-libcpp-undefined-symol-vtable-for-match_any_but_newline-exec.patch
printf 'cxx.libs += %s\ncxx.poptions += %s\n' \
"-L${EPREFIX}/usr/$(get_libdir) $($(tc-getPKG_CONFIG) sqlite3 --libs)" \
"$($(tc-getPKG_CONFIG) sqlite3 --cflags)" >> \
@@ -91,7 +92,6 @@ src_configure() {
config.bin.ar="$(tc-getAR)" \
config.bin.ranlib="$(tc-getRANLIB)" \
config.bin.lib=shared \
- config.install.chroot="${D}" \
config.install.root="${EPREFIX}"/usr \
config.install.lib="${EPREFIX}"/usr/$(get_libdir) \
config.install.doc="${EPREFIX}"/usr/share/doc/${PF}
@@ -107,5 +107,6 @@ src_test() {
}
src_install() {
- b install
+ b install \
+ config.install.chroot="${D}"
}