summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-10-10 06:28:42 +0000
committerSam James <sam@gentoo.org>2020-10-10 06:31:31 +0000
commit306fdab9eab759f62f25feb140882ea20257537e (patch)
tree23b29e766d29a3039447b4d706e2a6c7ef9bebf8 /dev-cpp/nlohmann_json
parentdev-python/progress: bump to 1.5, eapi7, add py3_9, unrestrict test (diff)
downloadgentoo-306fdab9eab759f62f25feb140882ea20257537e.tar.gz
gentoo-306fdab9eab759f62f25feb140882ea20257537e.tar.bz2
gentoo-306fdab9eab759f62f25feb140882ea20257537e.zip
dev-cpp/nlohmann_json: bump to 3.9.1
Closes: https://bugs.gentoo.org/728750 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-cpp/nlohmann_json')
-rw-r--r--dev-cpp/nlohmann_json/Manifest2
-rw-r--r--dev-cpp/nlohmann_json/nlohmann_json-3.9.1.ebuild57
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-cpp/nlohmann_json/Manifest b/dev-cpp/nlohmann_json/Manifest
index e64f5eccd1a1..e1b6029b11f7 100644
--- a/dev-cpp/nlohmann_json/Manifest
+++ b/dev-cpp/nlohmann_json/Manifest
@@ -1,3 +1,5 @@
DIST nlohmann_json-3.6.1.tar.gz 118862808 BLAKE2B 257508b33480741bd4438fe928869c0744a5e84806fa4e068b048bfc0e665802a45f31bc740c14f74e7a0384df18b9bba58a0e001750b1a800ea00cd1712b280 SHA512 e0565ccdee34e89a6836a97f039c04a0bac445b44f6f323918ea424b34e4577688a4f4f72d5ef1ec0b53d159bfe87e8e9c97b70ef98231ea463f59f05e16eb2a
DIST nlohmann_json-3.7.0.tar.gz 118868542 BLAKE2B 25191628b737ea5614de85d0fcb4425fcb2d37e6890626e6ba22949430a1c5f827ff17d1cd8245c8e98d0deda617d8268c55caff3017a6b4a2f730e524599311 SHA512 35510a0ee59d847ff9fcd4f4026ef936abb89675884fdd2db808f8349a55073206f764cd4f797deb1b6493ea0e04889505f49483e5b88798011dd5db87e7c87d
DIST nlohmann_json-3.7.3.tar.gz 119013476 BLAKE2B c10648cacdaf6f82aa2b1db49a412165eb9f3d00fd2b2232531077209c2add27dfebfb9dcd62e6923769411a471778a18a347b524e2ed3cf6f008883333ab8cd SHA512 c416b1e14f1fd695fc30a56127ca6440de4b334858ced54a6424d9d093e4665e74b7048f9ab7253ac02ac870e64a2868c78e6c2d6de80d1bd49e50a850cec865
+DIST nlohmann_json-3.9.1-testdata.tar.gz 112348454 BLAKE2B f0a47b41805bf1426f612e9a82efea2a3e5b1c15740c1c531d859e60dc5daeb85209b4fe363fd8fb84e3bbf01a2578c74538ba3e769726494047979f5a4d468d SHA512 d9af8419b837c592ec7519cd5772651c761078a9c43cf2a309cee55c323aee0df0c233fb58a07d5ee2e77492ac8b16398de234b387eae037a60e3c9ba5b08891
+DIST nlohmann_json-3.9.1.tar.gz 6882818 BLAKE2B 97276dc2345ac2070ac2d30d0a2e1953bb2f6ecde437eaed87dad46c108daa4b21c662a047e7d4e7c180179df9e7dfb71f545f3e42b2528201630d9093539090 SHA512 e0eb4727bea993af984f832e069d03a21219befae0f24ee49e67a1144cf1e8428dcf2e37f683aedb8d14118545d5087f2b7d822a576944cef3e590a12be51642
diff --git a/dev-cpp/nlohmann_json/nlohmann_json-3.9.1.ebuild b/dev-cpp/nlohmann_json/nlohmann_json-3.9.1.ebuild
new file mode 100644
index 000000000000..8c50916e83e9
--- /dev/null
+++ b/dev-cpp/nlohmann_json/nlohmann_json-3.9.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="JSON for Modern C++"
+HOMEPAGE="https://github.com/nlohmann/json https://nlohmann.github.io/json/"
+SRC_URI="https://github.com/nlohmann/json/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" test? ( https://github.com/nlohmann/json_test_data/archive/v3.0.0.tar.gz -> ${P}-testdata.tar.gz )"
+S="${WORKDIR}/json-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="doc test"
+#RESTRICT="!test? ( test )"
+# Need to report failing tests upstream
+# Tests only just added, large test suite, majority pass
+RESTRICT="test"
+
+DEPEND="doc? ( app-doc/doxygen )"
+
+DOCS=( ChangeLog.md README.md )
+
+src_configure() {
+ local mycmakeargs=(
+ -DJSON_BuildTests=$(usex test)
+ -DJSON_TestDataDirectory="${S}/json_test_data"
+ -DJSON_MultipleHeaders=ON
+ )
+
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ use doc && emake -C doc
+}
+
+src_test() {
+ cd "${BUILD_DIR}/test" || die
+
+ # Skip certain tests needing git per upstream
+ # https://github.com/nlohmann/json/issues/2189
+ local myctestargs=(
+ "-LE git_required"
+ )
+
+ cmake_src_test
+}
+
+src_install() {
+ cmake_src_install
+ use doc && dodoc -r doc/html
+}