summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2022-08-19 11:30:20 -0700
committerPatrick McLean <chutzpah@gentoo.org>2022-08-19 11:31:22 -0700
commit67fb969bd8947f7545dd1498592113a594f7cfc5 (patch)
treedf97cd3e536ff2ec0ca7dbcfe47814015c20f037 /dev-cpp/opentelemetry-cpp/opentelemetry-cpp-1.6.0.ebuild
parentapp-editors/emacs: Stabilize 28.1-r2 arm64, #865817 (diff)
downloadgentoo-67fb969bd8947f7545dd1498592113a594f7cfc5.tar.gz
gentoo-67fb969bd8947f7545dd1498592113a594f7cfc5.tar.bz2
gentoo-67fb969bd8947f7545dd1498592113a594f7cfc5.zip
dev-cpp/opentelemetry-cpp: add 1.6.0, fix bug #865029
Closes: https://bugs.gentoo.org/865029 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-cpp/opentelemetry-cpp/opentelemetry-cpp-1.6.0.ebuild')
-rw-r--r--dev-cpp/opentelemetry-cpp/opentelemetry-cpp-1.6.0.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-cpp/opentelemetry-cpp/opentelemetry-cpp-1.6.0.ebuild b/dev-cpp/opentelemetry-cpp/opentelemetry-cpp-1.6.0.ebuild
new file mode 100644
index 000000000000..d007ad4f6418
--- /dev/null
+++ b/dev-cpp/opentelemetry-cpp/opentelemetry-cpp-1.6.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="The OpenTelemetry C++ Client"
+HOMEPAGE="
+ https://opentelemetry.io/
+ https://github.com/open-telemetry/opentelemetry-cpp
+"
+SRC_URI="https://github.com/open-telemetry/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="+jaeger prometheus test"
+
+RDEPEND="
+ net-misc/curl:=
+ dev-libs/thrift:=
+ dev-libs/boost:=
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-cpp/gtest
+ dev-cpp/benchmark
+ )
+"
+
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ # remove tests the need network
+ "${FILESDIR}/opentelemetry-cpp-1.5.0-tests.patch"
+ # bug #865029
+ "${FILESDIR}/opentelemetry-cpp-1.6.0-dont-install-nosend.patch"
+)
+
+src_configure() {
+ local -a mycmakeargs=(
+ -DCMAKE_POSITION_INDEPENDENT_CODE:BOOL=ON
+ -DBUILD_SHARED_LIBS:BOOL=ON
+ -DBUILD_TESTING:BOOL=$(usex test)
+ -DWITH_JAEGER:BOOL=$(usex jaeger)
+ -DWITH_PROMETHEUS:BOOL=$(usex prometheus)
+ )
+
+ cmake_src_configure
+}