summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2022-08-19 11:31:08 -0700
committerPatrick McLean <chutzpah@gentoo.org>2022-08-19 11:31:22 -0700
commit0df47e74c92b5858ea15a80a77796f1b8378d2d9 (patch)
tree95ebc470d26cee35cc04a619cdc7bd643542f54f /dev-cpp/opentelemetry-cpp
parentdev-cpp/opentelemetry-cpp: add 1.6.0, fix bug #865029 (diff)
downloadgentoo-0df47e74c92b5858ea15a80a77796f1b8378d2d9.tar.gz
gentoo-0df47e74c92b5858ea15a80a77796f1b8378d2d9.tar.bz2
gentoo-0df47e74c92b5858ea15a80a77796f1b8378d2d9.zip
dev-cpp/opentelemetry-cpp: drop 1.5.0
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-cpp/opentelemetry-cpp')
-rw-r--r--dev-cpp/opentelemetry-cpp/Manifest1
-rw-r--r--dev-cpp/opentelemetry-cpp/opentelemetry-cpp-1.5.0.ebuild50
2 files changed, 0 insertions, 51 deletions
diff --git a/dev-cpp/opentelemetry-cpp/Manifest b/dev-cpp/opentelemetry-cpp/Manifest
index d1f17d8833bf..766567b2ffa4 100644
--- a/dev-cpp/opentelemetry-cpp/Manifest
+++ b/dev-cpp/opentelemetry-cpp/Manifest
@@ -1,4 +1,3 @@
DIST opentelemetry-cpp-1.3.0.tar.gz 710030 BLAKE2B 56aa3213fd9c9ac5266197c2ca417f5ff181ca28016033c9320e63122eaf9a53bdb265e1778227a9036bc42f8837755a3009cb23610268bc03b9fb24b3844c82 SHA512 38f613c208ec847c8bf7765732d8198fcc427c293a929945d72c2f739e89d2a0ad36be4d94cc3c1b77fd7b1f1d1e5d8bdb38094a493ba3da3125281cd1016836
DIST opentelemetry-cpp-1.4.0.tar.gz 722520 BLAKE2B c34867846708218e5ffcff9cdaa275e0c43201f681a68ad697d9f83ac04b7fdc6cdb69d942274cbe200b241e407ba11218c7e92da4f9adf4490e89c06388347f SHA512 a2339c0f9b2dc0d4f1964536a844241436bd68774445a0eab6e89e51965e01d3c40d2aa776d751eb497c50e9fdaa4e0023095efb14c8abbd6bbe23a2596eb3c9
-DIST opentelemetry-cpp-1.5.0.tar.gz 782336 BLAKE2B 11153dc8a219d3916c3d8aeb7575c2a98d5e8e094cbada096bfa03dd465a08a4fb09139ad22400e4b5693a5d740b8095618858256a2c5679ae080e4e3db16005 SHA512 a506973223c49531d4b0c3febf5734dfe2e44c22f8854ed96935cda0783a14d0819cc3dbb2d3f8373f960f27acf78aafc777ee76aeb14828df9c4b4434e4fe6f
DIST opentelemetry-cpp-1.6.0.tar.gz 790774 BLAKE2B 9512c092bfe49c9da82eff3950204c1f2eb654df2ed428e58ceb8877d15d80d9978fa6da37f7780352538c74de04bac69660528b255dfbce743f89b9d4020dd2 SHA512 ae0777451a3d2d676afd9f3142ab78c7afb08474f6038bd810ff0ee30fee6695e10100c901e7ffadf3faf16c7d19622acdea414cd720be8572f7720f2d528628
diff --git a/dev-cpp/opentelemetry-cpp/opentelemetry-cpp-1.5.0.ebuild b/dev-cpp/opentelemetry-cpp/opentelemetry-cpp-1.5.0.ebuild
deleted file mode 100644
index 2d70f1cdbd83..000000000000
--- a/dev-cpp/opentelemetry-cpp/opentelemetry-cpp-1.5.0.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="The OpenTelemetry C++ Client"
-HOMEPAGE="
- https://opentelemetry.io/
- https://github.com/open-telemetry/opentelemetry-cpp
-"
-SRC_URI="https://github.com/open-telemetry/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64"
-IUSE="+jaeger prometheus test"
-
-RDEPEND="
- net-misc/curl:=
- dev-libs/thrift:=
- dev-libs/boost:=
-"
-DEPEND="
- ${RDEPEND}
- test? (
- dev-cpp/gtest
- dev-cpp/benchmark
- )
-"
-
-RESTRICT="!test? ( test )"
-
-PATCHES=(
- # remove tests the need network
- "${FILESDIR}/opentelemetry-cpp-1.5.0-tests.patch"
-)
-
-src_configure() {
- local -a mycmakeargs=(
- -DCMAKE_POSITION_INDEPENDENT_CODE:BOOL=ON
- -DBUILD_SHARED_LIBS:BOOL=ON
- -DBUILD_TESTING:BOOL=$(usex test)
- -DWITH_JAEGER:BOOL=$(usex jaeger)
- -DWITH_PROMETHEUS:BOOL=$(usex prometheus)
- )
-
- cmake_src_configure
-}